www.immersionrc.com

Results 1 to 8 of 8

Thread: Firmware updating issue

  1. #1
    Navigator
    Join Date
    Oct 2012
    Posts
    21

    Firmware updating issue

    Hello
    I recently bought an ezuhf set, I was trying to install the latest firmware (1.25b). The program said the update was successful, but when I click read settings from transmitter, it still shows 1.25a.

    A display bug is my guess ?
    The same happens for the receiver.
    Last edited by Jaximus; 6th October 2012 at 10:46 AM.

  2. #2
    Navigator
    Join Date
    Oct 2012
    Posts
    7
    Same thing for me, I was tring to install firmware (1.25b) on my tx and rx. ImmersionRC updater say me it was successful but when I check read settings it continue to show 1.25a on tx rx!

    somebody know why ?

    Hugues

  3. #3
    Navigator
    Join Date
    Oct 2012
    Posts
    7
    I check my driver when I connect my ezuhf in upgrade mode. And I see ImmersionRC custom usb device. And I connect my EzUHF in normal mode I see ImmersionRC USB to UART(COM10). I think is normal, I check on immersionRC web page and I see every thing are normal in this side. Any people have this problem ? Any other Idea ? I have the same problem for TX and RX!

    Hugues

  4. #4
    Navigator
    Join Date
    Oct 2012
    Posts
    7
    Jaximus , do you find any thing is your side ? Do you have windows 7?


    Hugues

  5. #5
    Navigator
    Join Date
    Oct 2012
    Posts
    7

    Try update with windows XP

    I try updating my rx with windows XP and I have same problem. Cannot upgrade version 1.25b!

    Hugues

  6. #6
    Instagator
    Join Date
    Aug 2012
    Location
    Florida
    Posts
    81
    1. Go to the Immersion site:
    http://www.immersionrc.com/EzUHF.htm

    2. Download version 1.25b it is called EzUHFFirmware_v1.25b

    3. Unzip the file, open the folder and place the contents in the ImmersionRCTools folder

    4. The files should overwrite 1.25a

    5. Do the update again and you should have the proper version.

    Keith

  7. #7
    Navigator
    Join Date
    Oct 2012
    Posts
    7

    Solve

    Thanks keithm, It working. I don't know if thé problem Solve because i download again the file or It is because i replace firmeware inside the tools directory. Before i only browse and select the firmware in other directory.....

    Again thanks you for your help.

    Hugues

  8. #8
    Instagator
    Join Date
    Aug 2012
    Location
    Florida
    Posts
    81
    Hugues:

    Glad it's working for you.

    Keith

Similar Threads

  1. Firmware Location?
    By patrizio_g in forum SkylarkFPV
    Replies: 4
    Last Post: 30th September 2012, 02:16 PM
  2. Tiny OSD firmware
    By Reisender in forum SkylarkFPV
    Replies: 4
    Last Post: 5th July 2012, 11:22 PM
  3. OSD PRO firmware downgrade possible?
    By nocomp in forum Eagle Tree Systems
    Replies: 1
    Last Post: 19th June 2012, 10:15 PM
  4. Throttle not working till 50% issue (ESC to EZUHF issue)
    By SinaAzmoudeh86 in forum ImmersionRC
    Replies: 35
    Last Post: 28th May 2012, 05:23 PM
  5. EZUHF Updating Firmware - Is it NECESSARY ??
    By gtaero in forum ImmersionRC
    Replies: 1
    Last Post: 14th March 2012, 01:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •