Hello, I recently ordered a a XM+ and a qx7 but XM+ had EU firmware and the qx7 had the fcc Firmware. I tried to flash firmware on both of them-XM+:I tried flashing the latest fcc xm+ firmware but the eu XM+ is not responding even though it switches on. BTW, by mistake I had once connected gnd(batt) to the sbus port(rx) instead of the designated gnd port on the receiver. It had still switched on that time but now it is not responding(lights are flashing but it's not responding to firmware) when I connect gnd(batt) to the proper gnd port on the receiver. Have I blown the sbus port?the firmware isthe firmware ishttps://www.frsky-rc.com/xm-plus-mini-sbus-non-telemetry-full-range/i tried flashing all of themXM+FCC170313.frk: FCC MODE、full channels (ch1~ch16)XM+FCC170313-RSSI8.frk: FCC MODE、ch8 output RSSI.XM+FCC170313-RSSI16.frk: FCC MODE、ch16 output RSSI.XM+LBT170313.frk:LBT MODE、full channels (ch1~ch16)XM+LBT170313-RSSI8.frk: LBT MODE、ch8 output RSSI.XM+LBT170313-RSSI16.frk: LBT MODE、ch16 output RSSI.Qx7:My qx7 came with the fcc firmware and I tried to flash the Eu firmware to it to no avail. It says 'FIRMWARE FLASHED SUCCESSFULLY' but it is still in FCC mode as I can select all rx modes such as d8.the firmware ishttps://www.frsky-rc.com/xjt/ 170317