Page 97 of 427 FirstFirst ... 47879596979899107147197 ... LastLast
Results 961 to 970 of 4263

Thread: TBS DISCOVERY - New quadrocopter frame

  1. #961
    Dirtbag kloner's Avatar
    Join Date
    Mar 2012
    Location
    San Diego
    Posts
    1,035
    got my frame friday, that's much better....... quick question, just went and flew it's maiden and the current is high and the mah is showing about 20% more than it should. i selected the 100 amp sensor. What did i do wrong?

    thing is pitchy, gonna have to work on mellowing out the elevator, reminds me of flying a wing. I'll get used to it. new monitor, new radio, had alot of news this trip.

    welcome to mars

  2. #962
    Navigator
    Join Date
    Jun 2011
    Posts
    30
    Quote Originally Posted by kloner View Post
    got my frame friday, that's much better....... quick question, just went and flew it's maiden and the current is high and the mah is showing about 20% more than it should. i selected the 100 amp sensor. What did i do wrong?

    thing is pitchy, gonna have to work on mellowing out the elevator, reminds me of flying a wing. I'll get used to it. new monitor, new radio, had alot of news this trip.

    welcome to mars
    your video is on private

  3. #963
    is there some solder touching the shunt (big resistor right after the power wires)? that could skew the measurements. 20% seems way too far off ... 2-4% tolerance is normal.

  4. #964
    Quote Originally Posted by Trappy View Post
    TBS is running 4S 3.3 with 'em. 10-11min flight time on what are mostly very puffy lipo packs.
    Thanks bud!!

  5. #965
    Navigator
    Join Date
    Jun 2011
    Posts
    30
    here's my maiden flight on my discovery. a short fpv flight. hoping to do some more exciting fpv videos next time. first dixcovery in the Philippines and i'm a very proud owner.
    Last edited by mandis; 29th July 2012 at 09:05 PM.

  6. #966
    Navigator
    Join Date
    Jun 2011
    Posts
    30
    Quote Originally Posted by Trappy View Post
    TBS is running 4S 3.3 with 'em. 10-11min flight time on what are mostly very puffy lipo packs.
    what motor and prop size are you running them?
    thanks!

  7. #967
    I'm flying the 750kV RCTimers with 9x5 and 10x5 Graupner E-Prop and DJI ESCs (flashed ESCs coming soon!)

  8. #968
    Dirtbag kloner's Avatar
    Join Date
    Mar 2012
    Location
    San Diego
    Posts
    1,035
    I think this might have been connected, can't tell, can barely see it naked eye. There was the plasti dip stuff definately going across..... I'll have to try it out



    vids up now

  9. #969
    kloner that vid is just insane! really nice! I can't see anything wrong with the shunt. has it always been like this? did you have a short circuit in the CORE before?

  10. #970
    Dirtbag kloner's Avatar
    Join Date
    Mar 2012
    Location
    San Diego
    Posts
    1,035
    no shorts, it fired right up.... got it friday flew it sunday. it said my packs were 2500-2600 and got home to charge there all 2000-2100 back in. the amperage was running over 50 to, that's crazy high compared to the other one i was just flying with an eagle tree

Similar Threads

  1. C4 - Carbon Quadrocopter
    By Mechnan in forum ROTORCRAFT
    Replies: 31
    Last Post: 18th September 2012, 06:16 AM
  2. Mini FPV Quadrocopter
    By Bjorn in forum PILOT'S LAB
    Replies: 9
    Last Post: 5th October 2011, 08:49 PM
  3. New Tricopter Frame
    By timnilson in forum LUMENIER
    Replies: 15
    Last Post: 28th August 2011, 07:12 PM
  4. Discovery Channel Canada wants MY video!
    By aaron_gx in forum OFF-TOPIC
    Replies: 23
    Last Post: 16th March 2011, 08:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •