Results 1 to 3 of 3

Thread: RapidFire Stopped Working?!

  1. #1
    Forum Member
    Join Date
    Sep 2013

    RapidFire Stopped Working?!

    It was great while it was working but today it just stopped receiving video. This a relatively new module I got from getFPV earlier this month. It's only been out less than a handful of times. Any advice would be greatly appreciated as I really liked flying with it over the standard 5G8 module. Here are pics to show the issue ...

    This is showing my quad transmitting on Fatshark Band channel 4 (5800 freq) ...

    This is showing the Rapidfire set to IRC band channel 4 or 5800 freq.

    This is showing the static in the goggles even though it is set to the same frequency as the vtx in the quad.

    To rule out the goggles, I replaced the Rapidfire with a NexWave 5G8 module.

    This is showing a perfect picture in the goggles with the NexWave 5G8 module set to the right channel.

    Module "Brain" is v1.2.6, Rapdfire 1.1.2, and 4.9V (no low power).

    Sufficient power is being provided through the bridging of both L1 and L10 terminals on the internal boards (not through the headtracker power tap ribbon).

    Of note I tried using the Rapidfire Updater to patch 1.2.7 but I kept getting a "USB device not recognized" even though I had already updated the module before and applied a custom splash screen.

    I also tried running a calibration but it would always fail despite the vtx being clearly on and transmitting.

    Again any advise greatly appreciated. This was not a cheap piece of kit and kinda sucks that it doesn't work so fast!

  2. #2
    Forum Member
    Join Date
    Sep 2013
    Worryingly, I had accidentally applied a bit of pressure along the upper part of the LCD display while looking through the goggles and a picture appeared very briefly before going back to snow. What????

    Any help greatly appreciated cos for the price of this kit and the reputation of ImmersionRC, I really would have expected a LOT more than this piece of crap.

    [edit] Not sure why it would matter but just in case I'm using a TBS Unify Nano at 25mw and a Runcam Split Mini 2. And if it does matter, eff this module I'm getting another one that isn't so overpriced and crappy.

  3. #3
    Forum Member
    Join Date
    May 2013
    Send it back to getfpv.Ive have trouble with immersion rc for years and years,1 especially is an idiot.

Similar Threads

  1. rapidFIRE OSD not working properly
    By BuckyFPV in forum ImmersionRC Support
    Replies: 2
    Last Post: 14th April 2019, 07:50 PM
  2. HD v2 stopped working.
    By Ted_B in forum Fatshark Support
    Replies: 3
    Last Post: 3rd November 2016, 07:41 PM
  3. Replies: 5
    Last Post: 18th December 2014, 02:29 PM
  4. DJI H3-3D stopped working
    By Mechnan in forum RC TECH
    Replies: 1
    Last Post: 12th June 2014, 12:44 AM
  5. DJI H3-3D stopped working
    By Mechnan in forum Gimbals
    Replies: 0
    Last Post: 10th June 2014, 06:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts