Results 1 to 3 of 3

Thread: rapidFIRE OSD not working properly

  1. #1
    Forum Member
    Join Date
    Apr 2019

    rapidFIRE OSD not working properly

    I believe the rapidFIRE OSD is not working correctly in my FatShark HDO goggles, the following is a description of the behavior I am experiencing.

    In the following explanation I have a TX transmitting on Race 4 (R4), when I say 'joystick' I mean the rapidFIRE joystick.

    If I press the joystick up or down the OSD menu with the 8 channels does not appear on the screen as I would expect but if I take the goggles off the channels are indeed changing.
    With the goggles on as I push up or down I just see white noise until I find a channel then the menu appears but the OSD displays the wrong channel. If I cycle thru the channels pushing down joystick when I arrive at R4 the OSD then appears with R3 highlighted, if I take the goggles off I see I'm on actually on R4 not R3. If I don't press anything the menu disappears 3 seconds later leaving the video picture which is on R4.

    If I use the joystick up button when I arrive at R4 the OSD then appears but shows I'm on R5, if I take the goggles off I see on the external screen I'm on R4 not R5.

    So not only is the menu not coming on when I would expect it to come on to show me the channel but when it does come on it's showing the wrong channel.

    If I press the center joystick the menu appears and I can navigate around as expected, but when I come to band scan there is some weird behavior going on here too. It is possible to get the screen to go completely black and pushing joystick any way doesn't take it off the black screen, I have to cycle the power to get the picture back.

    When I first went through this I just thought this was how it was, I thought this OSD is pretty useless, then I watched Joshua Bardwell's video on You-Tube where I saw how it was supposed to work and I thought wow that looks pretty good.

    I've flashed the firmware on rapidFIRE to 1.2.6 with no errors, I have also tried 1.2.7 and its the same.

    Is this repair job or is there something I can try to fix this?

    Last edited by BuckyFPV; 14th April 2019 at 08:15 PM.

  2. #2
    Forum Member
    Join Date
    Apr 2019


    For me, Firmware update 1.2.8b solved this.

  3. #3
    Forum Member
    Join Date
    Sep 2013
    Theres a "b"??? I saw a 1.2.6 release and a 1.2.8 beta (no 1.2.7 lol?!) but no "b".

Similar Threads

  1. HD3 Headtracking (newer) quit working properly
    By RickBi in forum Fat Shark R/C Vision Systems
    Replies: 0
    Last Post: 21st October 2018, 11:38 AM
  2. LED Light board not working properly
    By Lincolnjt41 in forum Immersion Vortex Support
    Replies: 2
    Last Post: 21st January 2016, 02:29 AM
  3. Replies: 1
    Last Post: 17th August 2015, 02:39 PM
  4. Vector Not Working Properly?
    By Outdoorz in forum Eagle Tree Systems
    Replies: 5
    Last Post: 29th January 2015, 08:46 PM
  5. DVR-Display not working properly
    By gnrc in forum FPV-JAPAN
    Replies: 0
    Last Post: 31st January 2014, 02:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts