image
Results 1 to 2 of 2

Thread: EZOSD help needed

  1. #1
    Navigator
    Join Date
    Jan 2016
    Posts
    24

    EZOSD help needed

    Hey all, need some help here.

    I have just rebuilt my Happyflyers Wipeout wing after a good crash.
    I ditched the below average fc that was in it and grabbed the EZosd that I had rattling around in the spares drawer

    Now I have wired it all up and now I have crap video (rolling lines with throttle) and the osd flickers (also throttle related)

    Here's how it's wired.
    Click image for larger version. 

Name:	20190312_184835.jpg 
Views:	23 
Size:	138.3 KB 
ID:	78995
    Battery (3S) to current sensor.
    CS to Dual voltage stepdown (100uf cap in line)
    Stepdown 5V+G to camera, 12V+G to vtx
    Video from camera to osd
    Video from osd to vtx

    Osd powered via supplied cable from CS

    Previous setup had perfect video with no noise. Same camera, vtx, esc, motor, rx, servos, bec, stepdown

    Really need a solution before I cut into the brand new covering job.
    Yes I know I should have tested before sealing it all in.

    Thanks in advance

  2. #2
    Navigator
    Join Date
    Jan 2016
    Posts
    24
    Ok, so I just moved both the vtx and cam grounds from the stepdown to the osd. Flicker gone.

    Lines on video still there.
    Added a cap between current sensor and osd, no better.

    Have got no ferrite anywhere but not sure where it would be best placed to help.

Similar Threads

  1. Replies: 15
    Last Post: 10th August 2014, 07:34 PM
  2. Help needed in understand the EZOSD screen data
    By trivejb in forum ImmersionRC
    Replies: 4
    Last Post: 14th January 2014, 11:05 PM
  3. TBS EZOSD+TBS Core+TBS 69FPV+TBS EZOSD Current Sensor
    By para9111 in forum OSDs & Flight Controllers
    Replies: 2
    Last Post: 28th September 2013, 11:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •