Results 1 to 2 of 2

Thread: RC INPUT: NO Signal

  1. #1

    RC INPUT: NO Signal

    I have been working with customer support, but I have not been able to get good info. I sent it back they said everything was working fine, but I was still getting the same issue as before. I tested my crossfire unit on friends radio with the same out come. I was able to put his crossfire system in mine worked just fine. I was wondering if anyone else has had a similar problem. I think it's an issue inside the crossfire not making connection somewhere, As I can plug different crossfire into the same radio works perfectly.

    I just want to trade it out for a new one, but that doesn't seem like they are willing to do so, as I keep getting the response of it must be your radio, what I just wanted to exchange it for a different one. I offered to pay for everything too.

    I don't know what to do anymore as I can't call or seem to escalate this issue to a manager. I am not one who get upset, but I just want some empathy in this situation.

  2. #2
    I have similar issue. Always show RC INPUT: NO Signal. I have X9D+ & X-Lite, neither of them can work. If change to PPM/SBUS protocol, it can work.
    But i don't have other crossfire can test on my radio. My radio works perfectly with R9M and other Frsky module.

Similar Threads

  1. Replies: 7
    Last Post: 24th April 2016, 06:54 PM
  2. No Yaw input KK2.0 on 4s
    By EastCoast78 in forum OSDs & Flight Controllers
    Replies: 5
    Last Post: 11th May 2013, 02:39 PM
  3. Video Signal jammed naza fps signal???
    By rsequeira in forum Team-Black Sheep
    Replies: 4
    Last Post: 5th January 2013, 06:43 PM
  4. Need input FPV
    By Pellogt in forum IFR - Video Link Discussion
    Replies: 12
    Last Post: 22nd June 2012, 03:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •