www.immersionrc.com

Results 1 to 3 of 3

Thread: Rapid fire at 5v and going into low power

  1. #1
    Navigator
    Join Date
    Nov 2018
    Posts
    2

    Rapid fire at 5v and going into low power

    Ive done a search with no luck. If someone knows of a thread to help please direct me. I have fatshark dom3 with rapid fire. I have done the mod to the board. They worked no issue for a few days, but today they started to go into low power mode and they still show at 5v. Thanks for any advice.
    Click image for larger version. 

Name:	RAPIDFIRE.jpg 
Views:	24 
Size:	205.1 KB 
ID:	78879

  2. #2
    Navigator
    Join Date
    Apr 2019
    Posts
    2
    Have you found a solution?

  3. #3
    Navigator
    Join Date
    Nov 2018
    Posts
    2
    Yes. I found out there are 2 mods. The one on the dvr board and the other is on the top board. Once I did the top board I no longer any issues when the battery got below 50%.

Similar Threads

  1. Replies: 1
    Last Post: 16th April 2019, 10:33 PM
  2. Rapid fire door does not fit well
    By gencode in forum ImmersionRC Support
    Replies: 5
    Last Post: 8th August 2018, 09:15 AM
  3. Rear led off after rapid arm-disarm-arm
    By fallenwout in forum Immersion Vortex Support
    Replies: 3
    Last Post: 1st August 2016, 05:39 AM
  4. Vortex stops responding after rapid throttle input or rapid yawing
    By Swing3r in forum Immersion Vortex Support
    Replies: 0
    Last Post: 8th November 2015, 11:20 AM
  5. Fire in Attitude V1 - DON'T USE RC PACKS TO POWER GOGGLES
    By Svenska in forum Fat Shark R/C Vision Systems
    Replies: 10
    Last Post: 8th July 2015, 04:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •