Hi Guys,

I am a little stuck right now!
Before I bought and installed the TBS Nano Receiver I flew Frsjy XSRf4O AIO FC Flight Controller and the Frsky GPS Module V2 (connected via Smartport/UART6). Everything worked fine and I had the GPS data transmitted to my Taranis 9XD as a sensor.
Since I installed the Nano on UART3, no GPS data is transmitted/received. There is no GPS data although I tried to discover new sensors.

Is it possible that the data, that is received via Smartport, is not transmitted via the Nano???

If so, I would like to connect a M8N GPS module on the UART6, but my FC has only three pins on UART6 (ground, voltage and Smartport/S-Port). The M8N has four wires (Ground, voltage, RX and TX).

Is it possible to change any settings via the CLI in Betaflight, so I can connect the RX and the TX wires of the M8N GPS module while using UART6?

Or is it possible to take any pins of the UART1, that were used for the Frsky RX (before using the Nano)?

Motor output 5 and 6 are already used for Smartaudio and ESC-Telemetry.

Any other suggestions???

Help is really appreciated!