Results 1 to 2 of 2

Thread: Wrong GPS coordinates via MAVLINK

  1. #1
    Navigator hover's Avatar
    Join Date
    Sep 2012
    Location
    Austria
    Posts
    534

    Wrong GPS coordinates via MAVLINK

    Hello guys. I compiled Betaflight 3.5 with GPS rescue support and MAVLINK for my TBS Oblivion with the TBS Colibri fc. Working flawless, correct coordiantes in Betaflight!

    Now I activated MAVLINK on UART1 to see the GPS information on my Crossfire TX and in the OSD. Satellite count is working, but the GPS coordination format is wrong.
    I dont think its a wiring issue because the GPS is jumping and the satellite count is right. Maybe Betaflight sends a wrong GPS format or Xfire reads the coordinates wrong. Anyone has an idea?

    Thanks!

    Click image for larger version. 

Name:	gps.jpg 
Views:	29 
Size:	131.9 KB 
ID:	78762

  2. #2
    Hi hover, could you solve that? I have exactly the same issue...

Similar Threads

  1. Replies: 0
    Last Post: 9th August 2015, 12:33 PM
  2. Replies: 0
    Last Post: 3rd May 2015, 09:30 AM
  3. Coordinates GPS?
    By Franckdu29 in forum ImmersionRC
    Replies: 10
    Last Post: 23rd April 2014, 09:55 AM
  4. GPS Coordinates in EzOSD?
    By Wrecker in forum ImmersionRC
    Replies: 101
    Last Post: 29th December 2013, 04:00 PM
  5. Help me out with GPS coordinates:
    By Deadstick in forum OSDs & Flight Controllers
    Replies: 4
    Last Post: 4th October 2013, 02:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •