My Mojo works fine with the original Betaflight 3.2.2 and OSD 1.0.0.52 (which are the original ImmersionRC files actually).
I use the JETIEXBUS receiver protocol.

I'd like to update my Mojo to BF 3.5.6 (actuallly IRCSYNERGYF3 target is supported by BF 3.5.6 also).

Unfortunately, when I upgrade to another e.g. Betaflight 3.5.6 (for IRCSYNERGYF3 target) the OSD Wizard fails to recognize the stick positions in JETIEXBUS mode.
The same thing works fine with Betaflight 3.2.2, I tried several time to switch between 3.2.2 and 3.5.6. Always the same, works with 3.2.2 and fails with 3.5.6.
Actually Betaflight 3.5.6 is installed properly and is fine, just the Wizard seems to be broken.

Any ideas? API Version 1.36 vs 1.40 ?

regards
Alois