Results 1 to 6 of 6

Thread: Need help after wreck with FC

  1. #1
    Forum Member
    Join Date
    May 2018

    Need help after wreck with FC

    I just bought a drone from craigslist. It worked fine, flew it around etc.

    Took it to my brothers house, he had goggles on, I was line of sight.

    I launched it maybe 300ft, and then resulted in flying it into the earth for
    a very hard landing.

    the only thing that happened was a broken wire on the Rx the frame shifted, and the camera came unplugged.

    I brought it home and took it the top of the frame off and this is where the work began.

    GOGGLES : FatShark Dominator V3


    FC : Naze32 rev 5
    Rx : FS-IA6B
    MOTORS : DYS race edition se2205-2300kv
    ESC : DYS xm 20a oneshot 125 v2
    BATTERY : Floureon 11.1v 35c 1500mah
    CAMERA : eachines

    VTx and antenna I dont know. If i need to list something else please let me know.

    After i removed the cover I plugged the drone into my computer and connected it to cleanflight
    the FC was only bringing up CLI which I determine is the command prompt for the drone. I watched
    a few videos online on updating the firmware, or flashing the FC so I soldered the boot jumper, connected
    to clean flight and then I flashed with the most current firmware for NAZE32. I removed the solder jumper
    and plugged back into the drone. I was then able to see the board moving around on the cleanflight app
    as if it were a drone.

    I went to the motors tab and I was successfully able to power on all 4 motors so nothing was
    terribly damaged, so to say, The motors 1 and 2 sound significantly faster than motors 3 and 4.

    I downloaded and read the manual on my receiver the FlySky FS-I6. I managed to bind another Rx that I
    got in the craigslist lot, it is a FS-IA6. when binding it happened instantly, the FS-IA6B, no matter how many
    times I tried, it would not bind.

    Knowing that I have the Rx Bound to my flysky remote, and the VTx works with the goggles, the motors i know power on and the
    drone makes a lot of music like sounds when I power the battery on.. I am not sure what to do to get the FlySky remote to get the
    motors to turn and control the drone again..

    ANY HELP would be greatly appreciated, as I said, I literally just learned about drones, and I jumped straight into it.

    Thank you for reading this, and I anticipate a resolution to my dilemma.

    FLY SAFE!! o7

  2. #2
    Forum Member
    Join Date
    Feb 2016
    Take the props off while trying to figure this stuff out!

    The normal method to arm the quad is moving both sticks in and down, but there are options in the configuration program to allow for switch arming. (Then you have to configure a switch, etc.)

  3. #3
    Forum Member
    Join Date
    May 2018
    Thank you for replying I was begining to think that this was to no avail. ahha.

    Have the props off.

    When I first got the quad to arm it all of the switches had to be up, and then left joystick had to be down and then push it down and to the right and the motors would start up.

    The FLYSKY FS-I6, and the FC are both reset to default.. would it still be both in and down? i have nothing programmed in cleanflight as I am not sure where to start..

    Again ty so much, seeing I had a reply made my day!!
    Last edited by caveman1; 30th May 2018 at 08:42 PM.

  4. #4
    Forum Member
    Join Date
    Feb 2016
    It's been years since I messed with quads, I've moved on to airplanes and have been much happier ever since, so my answer was actually wrong . . . or at least is wrong now. I googled cleanflightstick commands and found this chart for ya.

    Click image for larger version. 

Name:	a63ab1e85c1b9358c301a8b32b893dafb764aa0c.png 
Views:	38 
Size:	76.3 KB 
ID:	78512

  5. #5
    Forum Member
    Join Date
    May 2018
    Thank you for that. I also joined a fb group maybe I can get this resolved by the weekend.

  6. #6
    Join Date
    Mar 2018
    Melbourne Australia
    Because you changed the Rx, Cleanflight maybe doesn't see it hence why it wont arm again?

    If your have the correct Rx selected in Cleanflight, maybe you need to change something on your Tx to suit.

    After a hard impact it can be a good idea to re-calibrate your accelerometer and motors again.

    Make sure the FC hasn't moved and check all the solder pads for any breaks.
    After awhile you will want to ARM via a switch instead of using the sticks, you'll get used to it.

    Its safer and saves you from dis-arming your quad whilst still in the air.

    Landings are much smoother also for when you throttle down to land, your other hand is already on the switch and you dis-arm just as you kiss the ground.

    Hope you get it back in the air soon, all the best.
    Last edited by 39LineFPV; 4th June 2018 at 08:27 AM.

Similar Threads

  1. Halifax Area, Nova Scotia! - FPV Parks and Wreck Dept.
    By Vintabilly_NS in forum EVENTS / MEETS
    Replies: 1
    Last Post: 15th May 2013, 08:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts