Results 1 to 2 of 2

Thread: Crossfire Nano RX issue

  1. #1
    Forum Member
    Join Date
    Oct 2014

    Crossfire Nano RX issue

    Hello, I'm a little bit lost because my nano rx worked well only one flight.
    I made the update on my micro TX to 2.24, and as soon as I've powered the nano CF freshly installed in my Rooster (with a CL racing F4 board), it automatically updates his firmware and was perfectly bound
    I made the maiden of the quad and everything went well. But the day after, when I tried to fly, the quad didn't armed.....then I saw the red led on the FC and discovered that the led button on the micro TX was blinking amber / orange, and telemetry on the screen of my taranis (x9D+) was not here.....but the nano RX had a fixed green led, even if I turn the radio off......
    Seems that the RX has lost his bind.......and I tried the restore fonction (with pushing the bind button on nano , powering it, then release (it starts flashing green quickly, but as soon as I push the button again for 9/10s, I have the fixed green led again and the TX is still "not bound" ......
    I tried updating to 2.25 ......same result.......
    What can I do? is it possible to flash it using a UART or something else (except Core or Fusion which I don't have (and I don't want to spend more money than a RX only to update the fw!)
    Thanks for your help
    Last edited by Bouata; 17th May 2018 at 01:03 PM.

  2. #2
    Forum Member
    Join Date
    Oct 2014

Similar Threads

  1. Crossfire Nano RX Issue
    By Thyhack in forum Team-Black Sheep
    Replies: 23
    Last Post: 3rd May 2018, 06:39 PM
  2. Replies: 1
    Last Post: 2nd May 2018, 07:56 AM
  3. Replies: 8
    Last Post: 17th April 2018, 06:28 PM
  4. crossfire with new t16sz issue
    By Tomstoy in forum Team-Black Sheep
    Replies: 3
    Last Post: 28th November 2017, 06:22 PM
  5. Channel Stability Issue - Dominator V2, FS NexWave 5.8, Altitude Nano vTx
    By jfg22557 in forum Fat Shark R/C Vision Systems
    Replies: 1
    Last Post: 15th August 2015, 01:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts