Results 1 to 6 of 6

Thread: Crossfire Bluetooth problem - requesting Perna's Assistance

  1. #1
    Navigator
    Join Date
    Jan 2015
    Location
    Milwaukee, Wi, USA
    Posts
    434

    Crossfire Bluetooth problem - requesting Perna's Assistance

    I turn Bluetooth on, on my crossfire and set it to mavlink and it doesn't show up on my android tablet Bluetooth list, my phones, nor my computer... Am I missing something? I borrow my friends transmitter and set it the same way and my laptop connects to it but mission planner won't connect to pixhawk thru the crossfire system, but a few months ago it did kind of work with mission planner, I could get a random connection but nothing useful but now I can't even get that but droid planner on my android tablet and phone works great.. Please help guys, any thoughts Perna?
    Last edited by Mark97564; 9th April 2018 at 03:47 PM.

  2. #2
    Navigator
    Join Date
    Apr 2018
    Posts
    4
    I'm having the same problem. Very rarely does Crossfire make itself visible to bluetooth. If I catch it visible, I can pair my laptop and use Mission Planner for a few minutes. I then hear telemetry lost, but all the electronics are sitting on the desk in front of me. After telemetry lost, I immediately regain telemetry but the bluetooth is gone. It's not visible or paired, just completely offline. I've had three such sessions. Grasping at straws, I upgrade to beta firmware 2.25. Boom, bluetooth is visible again...for a few minutes. In other words, no change. Any help out there?

  3. #3
    Navigator
    Join Date
    Jun 2017
    Posts
    9
    Bluetooth is also really unstable and super slow for me!

  4. #4
    Navigator
    Join Date
    Apr 2018
    Posts
    4

    Overheating

    Quote Originally Posted by danielschafer View Post
    Bluetooth is also really unstable and super slow for me!
    I send my unit into TBS, at my expense, and they opened up two trouble tickets. It's somewhat related to overheating, but I don't think either of the fixes involved heat. I haven't tested the patches because I ran out of time and, frankly, got tired of being a test engineer for TBS for free.

  5. #5
    Navigator
    Join Date
    Apr 2018
    Posts
    4
    There were a couple of Bluetooth bugs. TBS sent me a patch and, after a factory reset, patch application, and firmware downgrade to 2.33 I now have a working Bluetooth Mavlink connection. Yay!

  6. #6
    Navigator
    Join Date
    Jun 2017
    Posts
    9
    Thanks for feedback! In that case I'm looking forward to the next update!

Similar Threads

  1. crossfire bluetooth and tower app
    By TURBOTITO in forum Team-Black Sheep
    Replies: 7
    Last Post: 16th April 2018, 11:20 AM
  2. tbs crossfire connecting problem
    By lannylsz in forum Team-Black Sheep
    Replies: 2
    Last Post: 21st October 2017, 04:45 PM
  3. perna? TBS xfire,core pro with aftermarket gps?
    By doobie in forum TBS Support
    Replies: 2
    Last Post: 12th September 2016, 09:41 PM
  4. Vector UART Telemetry (Perna )
    By rangler in forum Eagle Tree Systems
    Replies: 2
    Last Post: 17th March 2016, 05:06 PM
  5. APM connecting to Bluetooth problem
    By jeepy in forum ROTORCRAFT
    Replies: 0
    Last Post: 27th April 2014, 03:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •