Results 1 to 6 of 6

Thread: TBS Discovery Pro gimbal moving back and forth ? lost stability

  1. #1
    Navigator
    Join Date
    Apr 2014
    Posts
    9

    TBS Discovery Pro gimbal moving back and forth ? lost stability

    Things that i did to trouble shoot are. Tested on different channels, different switches. Connected the giro motor to roll port on the board and the it still does moves about. Swapped the motor on the gimbal problem still precising. I am running out of options on any solutions i can test,change things around and im reaching out for some expert help. Any advice is much appreciated.

    Here is a short video of the problem, Too bad that the frame has been discontinued and i cant get any replacement parts for this engineering marvel that i truly enjoyed flying.


  2. #2
    Navigator
    Join Date
    Apr 2014
    Posts
    9
    Trappy, HELP!

  3. #3
    Co-Pilot doobie's Avatar
    Join Date
    Jan 2015
    Location
    ontario canada
    Posts
    1,525
    have you tried connecting to simpleBGC to see what error codes come up??? calibrate gimbal??? take IMU off see if cable connected???
    flyin HIGH

  4. #4
    Co-Pilot doobie's Avatar
    Join Date
    Jan 2015
    Location
    ontario canada
    Posts
    1,525
    flyin HIGH

  5. #5
    Navigator
    Join Date
    Apr 2014
    Posts
    9
    ok so it seems like the P value was too high at 9 and it was causing oscillations. Went from 9 to 5 and that seems like it made everything work like it should, the quads is completely dissembled and ill have to test it out in the air to see if the changes will take affect. Do you have any suggestions for the gimbal settings ?

  6. #6
    Co-Pilot doobie's Avatar
    Join Date
    Jan 2015
    Location
    ontario canada
    Posts
    1,525
    ya download the profile1 and profile2 from tbs website and install with the simple BGC. sets the gimbal up to recommended settings. works a charm for me. I find if I add the jello guard to the gopro I have to up the pitch motor power a tad, but that's all I seem to ever adjust usually.
    Last edited by doobie; 1st April 2018 at 10:01 PM.
    flyin HIGH

Similar Threads

  1. Lost video and brought it back
    By Kreskin in forum PILOT'S LAB
    Replies: 3
    Last Post: 28th January 2015, 07:56 AM
  2. TBS Discovery PRO stability problem
    By SwissFPV in forum TBS Support
    Replies: 46
    Last Post: 25th July 2014, 01:47 AM
  3. Gimbal Manual Control Setup - Pitch not Moving
    By teknovision in forum Team-Black Sheep
    Replies: 0
    Last Post: 24th December 2013, 07:15 AM
  4. Replies: 16
    Last Post: 10th July 2013, 04:25 PM
  5. Replies: 10
    Last Post: 28th April 2012, 12:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •