www.immersionrc.com

Results 1 to 5 of 5

Thread: Vortex 150 LEDS (Only One Side Works)

  1. #1
    Forum Member
    Join Date
    Dec 2017
    Posts
    3

    Vortex 150 LEDS (Only One Side Works)

    Hi guys, I purchased my first Vortex 150 in December directly on Amazon. After overcoming the initial learning curve, I was finally able to set it up perfectly, updated the firmware, etc.

    I performed my maiden flight on February. After my initial 2-3 min I landed it...no problem. Loved how well it flies. I flew it another 2-3 minutes and again landed it with no problem (No crash) but I noticed that only the right side of the LEDS were working. They WERE working before when I was setting it up and after the first flight. So I opened it up, checked all the connections, and reseated everything just in case something had become loose. No success. It is still failing . Everything else works fine.

    Can someone tell me what should I do?

    Robert.
    Last edited by RobertHabib; 16th March 2018 at 10:09 AM.

  2. #2
    Forum Member
    Join Date
    Apr 2016
    Posts
    1,943
    If you didn't crash it you should return it to your retailer and have it send in for warranty.

  3. #3
    Forum Member
    Join Date
    Dec 2017
    Posts
    3
    I totally agree. I should have. It’s late for me now.

    The learning curve required I dedicate more time than I had anticipated to figure it out. Every time I had a chance to get to it (I was busy with work) it became complicated because it was not being recognized by Windows.

    Only until I eventually found the software and tools I needed in the Vortex 250 download section (the Vortex Configurator, the ImmersionRC Drivers and the ImmersionRC tools) was I able to perfectly set it up. By the time I was ready to fly I was at the end of February. The bottom line, I was way over the 30 days. I took too long learning to set it up. It's simply too late to return to the retailer.



    A long story short, although I have not “officially” crashed it, I imagine that by now you guys would not want to honor the warranty. It already has scrapes on the propellers caused by hanging twigs and landing on the grass. This baby is called "Mini" but it can fly fast .

    The LED issue, It seems to be, by what I've been able to read about in this forum, a quite common issue with brand new units. It flies perfectly and it's BEAUTIFUL, I LOVE IT. I would really like the lights to turn on for me. I haven't been able to enjoy them. Would you kindly guide me on what do I need to do to fix it?

  4. #4
    Forum Member
    Join Date
    Apr 2016
    Posts
    1,943
    pls contact repairs@immersionrc.com and see if they can assist you.

  5. #5
    Forum Member
    Join Date
    Jul 2016
    Location
    Walking over to pick up the pieces
    Posts
    179
    Quote Originally Posted by RobertHabib View Post
    I totally agree. I should have. It’s late for me now.

    The learning curve required I dedicate more time than I had anticipated to figure it out. Every time I had a chance to get to it (I was busy with work) it became complicated because it was not being recognized by Windows.

    Only until I eventually found the software and tools I needed in the Vortex 250 download section (the Vortex Configurator, the ImmersionRC Drivers and the ImmersionRC tools) was I able to perfectly set it up. By the time I was ready to fly I was at the end of February. The bottom line, I was way over the 30 days. I took too long learning to set it up. It's simply too late to return to the retailer.



    A long story short, although I have not “officially” crashed it, I imagine that by now you guys would not want to honor the warranty. It already has scrapes on the propellers caused by hanging twigs and landing on the grass. This baby is called "Mini" but it can fly fast .

    The LED issue, It seems to be, by what I've been able to read about in this forum, a quite common issue with brand new units. It flies perfectly and it's BEAUTIFUL, I LOVE IT. I would really like the lights to turn on for me. I haven't been able to enjoy them. Would you kindly guide me on what do I need to do to fix it?
    Since the LED's are soldered directly onto the PDB, the only way to fix them is to put in a new PDB. Replacing the pdb requires a decent amount of soldering and isn't really worth it especially if its just the 2 LED's giving you trouble. I would still give Amazon a shot, as they have taken stuff back that was 2+ months out of return date for me. Or contact IRC support and send it to them.

Similar Threads

  1. Problem with vortex 285
    By RecklessFpv in forum Immersion Vortex Support
    Replies: 21
    Last Post: 25th April 2017, 09:47 PM
  2. Vortex 150 problem :(
    By funkfreed in forum ImmersionRC Support
    Replies: 5
    Last Post: 12th March 2017, 02:43 AM
  3. Vortex 250 PRO OSD problem
    By minras in forum ImmersionRC Support
    Replies: 8
    Last Post: 19th February 2016, 10:10 AM
  4. Problem Vortex pro
    By AlexT2 in forum Immersion Vortex Support
    Replies: 14
    Last Post: 20th January 2016, 12:42 PM
  5. Vortex OSD problem Please Help!!!
    By BANDIT3700 in forum ImmersionRC Support
    Replies: 1
    Last Post: 12th January 2016, 02:28 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •