www.immersionrc.com

Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Vortex 285 will not properly initialize

  1. #1
    Navigator
    Join Date
    Sep 2016
    Posts
    47

    Unhappy Vortex 285 will not properly initialize

    I purchased a vortex about 2 weeks ago. I ran through the quick start guide and got everything set up fine, it would initialize properly, most of the time, and all was fine.

    I had a hard landing a couple days ago and since then I have had nothing but trouble. After that hard landing the Led lights would not come on but I could arm it and fly just fine. I started searching for an answer and found that I may need to flash the firmware. So this morning I did just that. Now the LEDs come on but stay a solid color. They do not show the system check. I have calibrated the accelerometer and run through the wizard several times now to no avail.

    When I press the button on the LED board all that it does is change the LED colors. No frequency change and no entering into the wizard.

    boot loader version 1.0.0.2 Firmware version 1.0.0.43

    When I plug in the battery I get a series of tones but the tones are not what I remember. I find it easier to show rather than tell you what is happening so I made this video.

    https://youtu.be/UEkTDHs5oX4

    any help will be greatly appreciate in this matter. While I can still fly I want to get this thing right.

  2. #2
    Pilot JCLs's Avatar
    Join Date
    Dec 2013
    Location
    Houston, TX
    Posts
    1,045
    The LED board is notorious for failure you have described. Is usually caused by broken connection between the two boards. I could not get mine to work and bought and installed new led board and it worked fine. I could Fly mine fine with board screwed up.


    Sent from my iPad using Tapatalk

  3. #3
    Navigator
    Join Date
    Sep 2016
    Posts
    47
    Thanks JC. I would like to get confirmation from IRC on this. I shouldn't have to buy a new LED board on a 2 week old quad.

  4. #4
    Navigator
    Join Date
    Sep 2016
    Posts
    47
    Thanks JC. I would like to get confirmation from IRC on this. I shouldn't have to buy a new LED board on a 2 week old quad.

  5. #5
    Navigator
    Join Date
    Jul 2016
    Location
    Walking over to pick up the pieces
    Posts
    179
    Quote Originally Posted by Wildvortex View Post
    Thanks JC. I would like to get confirmation from IRC on this. I shouldn't have to buy a new LED board on a 2 week old quad.
    Yeah, the 285 LED boards were not exactly that robust. You might be able to fix it by reflowing the solder on the contact points on the board, that fixed mine temporarily, but other than that, you might be stuck with a dead led board. As long as the quad flys fine, I would not bother with replacing it.

  6. #6
    Navigator
    Join Date
    Sep 2016
    Posts
    47
    That is what I plan on doing for the time being. I really am not happy about it on a 2 week old quad. It's not like I am racing it and crashing it into Gates and such. This is just from general flying and probably only have about 20 flights on it if even that. First ImmersionRC product but as it stands right now it could very well be the last.

  7. #7
    Navigator
    Join Date
    Sep 2016
    Posts
    47
    This thing is driving me nuts! So, I fixed the solder runs and checked continuity to the voltage regulator and IC legs from the different connections. Have good continuity there. Locked the board into place by putting it all back together then soldered the connections for the LED board. Plugged it in and the LED lights worked perfectly.

    The next time I plugged it in not a single light came on. I am beginning to think that there is something else going on.
    I reflashed the the OSD then the FC with the Vortex Configurator as instructed. Still nothing. Can anyone tell me what the lights mean on the FC? I know the Blue light flashing is normal. What does the red light indicate. Once it has initialized the green light goes out and I just have red.

  8. #8
    Pilot JCLs's Avatar
    Join Date
    Dec 2013
    Location
    Houston, TX
    Posts
    1,045
    If the quad flies, all is good. The board is an irritating PITA. I have been there. Took new board to fix.


    Sent from my iPhone using Tapatalk

  9. #9
    Navigator
    Join Date
    Sep 2016
    Posts
    47
    Yup, flys like a dream. Been thinking of just unsoldering the RX and TX legs hoping to get illustration all of the time. Atleast it would have a directional light when flying LOS.

    Very poor designs on some aspects with this one. Only thing holding a battery wire is a solder pad on just one side of the board, Nothing through the board...come on now. Seems someone is looking for money in selling all the boards to keep it flying

  10. #10
    Navigator
    Join Date
    Sep 2016
    Posts
    47
    JCLs, I did finally break down and buy a new LED board. Works great now. I was contacted buy IRC support. All they kept doing was making me jump through hoops with video this and video that. It was crazy "show us now what happens when you press the button for 8+seconds. Does it go into the wizard?" I mean, the video shows that the LEDs are not coming on at all. That should be all the matters! I have no faith in IRC's customer support.

Similar Threads

  1. Vortex 250: motor not starting properly, weird behaviour
    By paxos in forum Immersion Vortex Support
    Replies: 1
    Last Post: 17th May 2016, 04:57 PM
  2. Vortex 250 Won't start properly
    By cronicryo in forum Immersion Vortex Support
    Replies: 2
    Last Post: 13th May 2016, 01:49 AM
  3. Vortex doesn't Jaw properly.
    By JavierBayArea in forum ImmersionRC Support
    Replies: 26
    Last Post: 15th June 2015, 04:10 PM
  4. DVR-Display not working properly
    By gnrc in forum FPV-JAPAN
    Replies: 0
    Last Post: 31st January 2014, 02:13 PM
  5. mount it properly
    By brosius85 in forum FIXED WING
    Replies: 19
    Last Post: 13th November 2011, 05:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •