www.immersionrc.com

Results 1 to 3 of 3

Thread: Vortex 150 Motors Stuttering. Wont spin up

  1. #1
    Forum Member
    Join Date
    Sep 2014
    Posts
    37

    Vortex 150 Motors Stuttering. Wont spin up

    I had a motor quit working a few weeks ago (stuttering) and I replaced all 4 motors with Kong 1306 motors. Now only one spins up nicely. One is trying to spin up and the other two are stuttering.

    I have checked all settings resoldering one motor, checked voltage at PDB and esc, LED on esc is lit.

    Its almost like there outta synch but you cant access them via BLheli and the web site said you cant calibrate them anyways

    Ideas ?

    https://youtu.be/BfPvOdq86k8

  2. #2
    Forum Member
    Join Date
    Apr 2016
    Posts
    1,943
    The esc use our own special firmware. If you solder back a stock motor to the esc does it work then? If yes, it's the new motors that aren't compatible.

  3. #3
    Forum Member
    Join Date
    Sep 2014
    Posts
    37
    Quote Originally Posted by ImmersionRC Support View Post
    The esc use our own special firmware. If you solder back a stock motor to the esc does it work then? If yes, it's the new motors that aren't compatible.
    Exactly what I ended up doing and stock motor worked

    put the new motor back on and no worky

    kept messing with it and eventually got smoke from new motor and now esc gets very hot

    FYI. the wires n the stock motors is very soft and very brittle

    what would make a motor not compatible? I have seen others swap out stock motors. One motor worked ok

    i have a 300 dollar paper weight. I will need new esc's that will work with my new motors and hopefully the one motor that smoked a little is still ok. This thing is costing me a small fortune all because one motor quit working. I didn't buy stock motor because none were in stock anywhere

    all that proprietary hardware is killing me. Could prove very difficult to use another frame even

Similar Threads

  1. VORTEX BEEP AND ONLY 3 MOTORS SPIN - WITH VIDEO.
    By kassysimon in forum Immersion Vortex Support
    Replies: 11
    Last Post: 6th May 2016, 05:04 AM
  2. vortex one motor wont spin
    By anthonymaniti in forum Immersion Vortex Support
    Replies: 1
    Last Post: 25th October 2015, 09:48 AM
  3. Replies: 12
    Last Post: 27th September 2015, 11:26 PM
  4. eagle tree vector..motors wont disarm or spin
    By rodneysimpon85 in forum OSDs & Flight Controllers
    Replies: 0
    Last Post: 14th October 2014, 10:03 AM
  5. Stuttering motors on new build
    By UVflyer in forum RC TECH
    Replies: 0
    Last Post: 25th April 2013, 04:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •