www.immersionrc.com

Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: New Vortex 285 not working.

  1. #1
    Navigator
    Join Date
    Mar 2017
    Posts
    6

    Unhappy New Vortex 285 not working.

    Hi,
    I am unable to get my new drone in the air. I connected it to both a Radiolink AT9/R9DS and a Flysky /FS-IA6 and nothing. It also will not connect to Betaflight or Cleanflight. I am relatively new to quads and at a complete loss. I have scoured youtube and many other forums and have been trying to get it going for 3 days and have had no luck. Please Help.

  2. #2
    Navigator
    Join Date
    Feb 2017
    Posts
    18
    I'm also new to the Vortex but: I have not even tried to use any software to enhance my Vortex. Right out of the box, run the startup routine as viewed in the FPV goggles and your good to go. I'm not into the race thing but I do enjoy the speed and agility of the Vortex. I have to admit, at my age, its probably not the best choice of quad but I'm adapting to its speed pretty well. Keeping orientation is my biggest challenge....getting off the subject, sorry.
    I don't know what any software upgrades would do for my Vortex and flying, I'm pretty happy with the out of box experience.

  3. #3
    Co-Pilot ImmersionRC Support's Avatar
    Join Date
    Apr 2016
    Posts
    1,943
    Honestly, if you are running in these issues it is almost impossible for us tho diagnose your issue. But let's see if we can get you in the air. Are your rx ppm or sbus? If they are sbus you need a converter cable.

  4. #4
    FPV Techanic RonSII's Avatar
    Join Date
    Dec 2011
    Location
    PNW USA
    Posts
    3,415
    @Kellz, I did a bit of quick looking around and it looks like your radiolink is sbus and the flysky is not ppm... not completely sure but from what issues I see people having am not sure you can get the correct ppm signal out of it except maybe with a firmware change.... some of these receivers you can short pins together and change the data mode but I don't know on these I see a lot of contradictory info out there.

    What codes if any does the vortex show when either of these rx's are connected?

  5. #5
    Co-Pilot ImmersionRC Support's Avatar
    Join Date
    Apr 2016
    Posts
    1,943
    I believe both are sbus receivers and for those too work you need the sbus to ppm cable like this:
    http://www.getfpv.com/vortex-sbus-futaba-ppm-cable.html
    https://www.multirotorparts.nl/immer...ppm-cable.html

  6. #6
    Navigator
    Join Date
    Mar 2017
    Posts
    6
    Thanks, Everyone.. I just ordered the cable and will let you know how it turns out

  7. #7
    Co-Pilot ImmersionRC Support's Avatar
    Join Date
    Apr 2016
    Posts
    1,943
    good let us know how it goes.

  8. #8
    Navigator
    Join Date
    Mar 2017
    Posts
    6
    Hi guys,

    I got my cable (ImmersionRC Brand) in, hooked it up and still nothing. Both RX are configured and connected but the quad is not responding and still will not connect to Beta/Cleanflight. It beeps continuously and after being powered up for about 30 seconds, the tail LEDs begin flashing red.
    Click image for larger version. 

Name:	IMG_2586.jpg 
Views:	37 
Size:	303.7 KB 
ID:	76608

  9. #9
    Navigator
    Join Date
    Feb 2017
    Posts
    18
    You did remember to bind the receiver to the radio...my assumption?

  10. #10
    Navigator
    Join Date
    Mar 2017
    Posts
    6
    I bound 2 tx/rx pairs.

Similar Threads

  1. How to get RSSI Working on Vortex 250 Pro?
    By M6Trouble in forum Immersion Vortex Support
    Replies: 1
    Last Post: 29th July 2016, 10:16 AM
  2. Vortex Video Not Working
    By F1Chase in forum Immersion Vortex Support
    Replies: 11
    Last Post: 8th January 2016, 10:53 PM
  3. Vortex Altimeter not working
    By Sealord in forum ImmersionRC Support
    Replies: 4
    Last Post: 28th December 2015, 07:05 PM
  4. Vortex motors don't working
    By Dor.b in forum ImmersionRC
    Replies: 8
    Last Post: 18th August 2015, 05:58 PM
  5. Vortex Alt not working
    By IronRotor in forum ImmersionRC
    Replies: 16
    Last Post: 13th July 2015, 03:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •