Results 1 to 2 of 2

Thread: Flysky TH-9x binding problem.

  1. #1
    Forum Member
    Join Date
    Feb 2016

    Angry Flysky TH-9x binding problem.

    Ive looked on most threads and youtube vids but so far I havent gotten any other ideas why my Flysky th9x isnt binding to the FS-r9b that came with it just today. Any suggestions? I dont have a plug to attach power directly to the receiver like I saw some wheres on a comment. Just going through my emax 280, I have everything plugged in correctly, esc board and wires plugged in. Also tried just binding and CH1 wires (yellow, orange, brown) in 3 slot and BAT slot but still flashing.. I tried a few different wire combos but still I see the rapid flashing bind light and nothing solid. I hope theres a better answer out there other than something just doesnt work so I m crossing my fingers. Any help is much appreciated.

  2. #2
    Forum Member
    Join Date
    Feb 2016
    So I found out soon after this post that I was making a stupid mistake and the problem is way past fixed. Since then I have enjoyed my quad like crazy and I m hooked for live.

Similar Threads

  1. EzUHF binding problem
    By chuckgaudette in forum ImmersionRC Support
    Replies: 20
    Last Post: 26th September 2014, 01:17 PM
  2. FlySky i10
    By Siv in forum RC TECH
    Replies: 14
    Last Post: 24th July 2014, 04:47 PM
  3. Replies: 7
    Last Post: 16th July 2014, 02:12 PM
  4. Binding Mode /Calibration mode problem
    By deadlypope in forum DragonLink RC
    Replies: 3
    Last Post: 25th March 2014, 06:23 AM
  5. Replies: 15
    Last Post: 11th November 2013, 04:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts