Results 1 to 2 of 2

Thread: Cricket V2 200: fried after applying 14 Volts

  1. #1
    Navigator
    Join Date
    May 2011
    Location
    Austria
    Posts
    57

    Cricket V2 200: fried after applying 14 Volts

    Hi all,

    I am having an issue with the "RMRC Cricket V2 - 5.8GHz Video Transmitter w/ Race Band - 200mW (RMRC-CRICKETV2-200)".


    Here's the story:
    I attached one Cricket vtx to my quadcopter on the bench. For testing I always use just a small 2S battery. Results were promising, the transmitted picture was clear and consequently I switched to a 3S battery. Bad idea, the Cricket vtx fried instantly.


    I rechecked but could not find any mistake. Upon this I tried a second unit of a Cricket V2 200. Same issue, no problems with 2S but when I switched to (this time) 4S also this unit fried.

    Did I miss something?

    Cheers, Stefan

  2. #2
    Navigator
    Join Date
    May 2011
    Location
    Austria
    Posts
    57
    anybody who uses the RMRC Cricket V2 with more than +5V?

Similar Threads

  1. Cricket V1 stuck on one channel
    By finnsquared in forum RMRC Support
    Replies: 2
    Last Post: 16th June 2016, 05:41 PM
  2. 200mW Cricket quite warm on bench
    By learn2turn in forum ReadyMadeRC
    Replies: 1
    Last Post: 25th April 2016, 09:44 PM
  3. RMRC Cricket VTX Stock Status
    By neonbjb in forum ReadyMadeRC
    Replies: 7
    Last Post: 15th December 2015, 03:13 PM
  4. Cricket 200mw 5.8 video Tx
    By salmans21 in forum ReadyMadeRC
    Replies: 8
    Last Post: 24th November 2015, 10:58 PM
  5. Help Disco Pro Endurance Unstable when applying clockwise yaw
    By GreyThePenguin in forum TBS Support
    Replies: 0
    Last Post: 7th November 2015, 08:09 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •