Hi everyone. This problem has been driving me nuts for months and I feel like I've tried everything. Hopefully someone here can help.

I purchased a 1.3ghz FPV package from readymaderc in January and it's never really worked. I fly quads in my spare time and so it's taken a while to completely troubleshoot.

The issue:

- A blinking / winking type of interference, even at close distances but that gets worse the farther I go.
- Poor range (Less than 300m).


If the distance between the transmitter and receiver doesn't change (i.e. I set the quad on the ground and stand in one place with the display, or walk around holding the quad in one hand and the display in the other) the winking stops and the video is solid.

What I've done to troubleshoot:

- Different channels (only 2 available are 1258ghz and 1280ghz)
- Powering the video transmitter and camera with it's own 3S 1100mah Lipo. (Everything on the quad is off)
- Different antenna combinations. VAS RHCP Cloverleaf antennas, stock 1.3ghz whips, 8db patch. No difference between any of them.
- Using different displays
- Removing the VTX heatsink case
- Shielding the transmitter
- Re-adding the VTX heatsink case
- Replacing the camera with a Sony Super HAD CCD 600TVL
- Checked and re-soldered any connections.
- Testing in different locations (I live about 20 minutes from Nashville, but tried in Alpharetta Georgia with same results).

Before eventually testing the VTX on its own battery (ruling out interference from other components or dirty power from a shared battery) I had tried:

- LC filters
- Ferrite rings
- Replacing the radio transmitter with a Turnigy 9XR
- Switching control to an LRS system (ImmersionRC EZUHF). Different UHF frequencies, hopping, etc
- Shielding the UHF RX and TX
- RF filters (VAS UHF/1.3 Notch on EZUHF TX and 800ghz HighPass on VRX etc.)
- Moving placement of the VTX, antenna, other components like the EZUHF TX, etc. No change.

Any idea what could be causing this?