www.immersionrc.com

Results 1 to 3 of 3

Thread: Vortex 250 Won't start properly

  1. #1
    Navigator
    Join Date
    Mar 2016
    Posts
    5

    Vortex 250 Won't start properly

    it beeps 3 times then two lower then two higher
    then the leds on the bottom start to turn on one by one
    5 green then 1 red

    then they all flash red and stays solid
    any one have any ideas wtf is going on

  2. #2
    Co-Pilot ImmersionRC Support's Avatar
    Join Date
    Apr 2016
    Posts
    1,943
    Pls check your camera cable.

  3. #3
    Navigator
    Join Date
    Mar 2016
    Posts
    5
    After I posted this I did find another post that said to check that and long behold one of the wires disconnected. Hey immersion support just a inquiry there's barely any docs on what any of the warnings mean or even how to put the go pro mount together. Some documentation would be a great resource. I wouldn't think I couldn't fly without a camera.
    Thanks for the quick response though


    Sent from my iPhone using Tapatalk

Similar Threads

  1. Vortex 285 - Motors will not start (Arm)
    By wrong17 in forum ImmersionRC
    Replies: 3
    Last Post: 10th February 2016, 02:32 PM
  2. After fusion board swap, sometines vortex don't start, just beep
    By LesAiles in forum Immersion Vortex Support
    Replies: 0
    Last Post: 17th December 2015, 03:42 PM
  3. Vortex doesn't Jaw properly.
    By JavierBayArea in forum ImmersionRC Support
    Replies: 26
    Last Post: 15th June 2015, 04:10 PM
  4. ImmersionRC: please start selling the Vortex Powerboard
    By JavierBayArea in forum ImmersionRC
    Replies: 0
    Last Post: 13th June 2015, 09:24 PM
  5. mount it properly
    By brosius85 in forum FIXED WING
    Replies: 19
    Last Post: 13th November 2011, 05:39 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •