Results 1 to 4 of 4

Thread: Lux-Lite FC - Guidance / How to Configure for use with FrSky X8R / Taranis using SBUS

  1. #1
    Navigator
    Join Date
    Jul 2016
    Posts
    4

    Lux-Lite FC - Guidance / How to Configure for use with FrSky X8R / Taranis using SBUS

    Hello everybody, I am new here to both the forum and to RC quadcopters. I am looking for guidance on how to configure my recently purchased Lumenier Lux-lite flight controller for use with my FrSky X8R Tx and Rx using SBUS. I've found that the manual is more or less useless for anything other than identifying what the pinout is of the FC. The manual literally says "download cleanflight to configure" and that is it.

    I held the boot button while powering on, then installed the drivers using Zadig as described in the manual. I downloaded cleanflight and successfully connected to the Lux-lite. I changed the receiver mode to Rx-Serial to use SBUS as it describes. I adjusted the yaw alignment to 270 degrees because I installed the flight controller without the arrow facing towards the front of the craft. I saved and rebooted and when I rotate the quad physically in my hand, the model rotates along with it. I have a connection which appears to be perfectly functional with the cleanflight app.

    I turned on my Taranis controller and binded it to the X8R by holding the F/0 button. The X8R Rx made a noise and blinked repeatedly. The bind was successful. I restarted the Lux-lite and sure enough, the Taranis Tx in my controller is communicating wtih the Rx connected to the Lux-lite. All appears to be great.

    I now plug in my battery which is a Lumenier 2550mAh 4s 14.8v battery. As soon as the Lux-lite see's potential from my battery (vs when sourced via USB from my computer), the motors begin a repeated and cyclic "blip" accompanied by a loud "BEEP". This occurs on a cycle every ~0.5 seconds. I confirmed that the ground wire (brown) from each 420 lite ESC is connected to the G associated with each 1,2,3,4 pad. I also confirmed that the orange wire from each ESC is connected to their corresponding 1,2,3, and 4 pads on the Lux-lite. The lux-lite is successfully communicating with the cleanflight app, and on board gyro and accelerator are working as expected. The Lux-lite and all 4 ESCs are wired through a power distribution board, which all are connected properly to the source battery. Rx on the Lux-lite is connected to the connection on the X8R labeled as the signal (symbol of a square wave pulse), as well as 5v to 5v on the Lux-lite, and ground.

    I for the life of me cannot find a physical problem with any hardware, any connections, or how I've got them connected. I suspect that because the Lux-lite is clearly communicating to the Cleanflight app, that it must either be a problem with my configuration in Cleanflight -- OR -- a problem with my setup of my Taranis.

    I will take pictures and record a video to upload over the next hour or so and post them up.

    Any help in troubleshooting this would be greatly appreciated as this a lot to absorb for a newcomer. I suspect it is something that may be obvious to a more seasoned veteran of the hobby. Anyway, thanks in advance for any help you guys might be able to provide.

  2. #2
    Navigator
    Join Date
    Jul 2016
    Posts
    4
    So after hours of hunting and reading, I've read that the ESCs will pulse the motors when no signal is being received. This appears to be my issue: No signal from the FC to the motors.

    I've opened up cleanflight and checked on the receiver tab to ensure my Taranis is sending commands to the FC. All roll, pitch, yaw, and throttle commands appear between 987 min and 2011 max. The problem looks like the FC is receiving the commands from the X8R receiver, but not sending commands to the motors. So when I try to calibrate the ESCs, they do not respond to raising the master raise bar in the motors tab of cleanflight/betaflight. I've got my Tx setup to output 1000 - 2000. I've got cleanflight's min and max throttle set to 1050 - 2000, with the center at 1500 and min command set at 1000. So I believe this is correct and calibrated properly.

    Some sites say you need to be in stabilize mode to arm. Any idea what this is?

    I figure, because I need the FC to tell the motors to go to 2000uS to calibrate them, there must be a problem with the Lux-lite FC outputting the signal to the motors. So I should make sure I have SBUS setup correctly first. I know from reading the Lux manual that the Serial RX pad on the bottom of the board must be bridged to the center pad. Also, because I'm using FRSky, the 5v pad must be also be bridged to the center pad -- these look fine. In settings on cleanflight, I have the serial receiver provider set to SBUS, and the receiver mode set to Serial based (for SBUS). I figure I should also have the port using SBUS setup for serial Rx, so using the ports tab - I am not quite sure which port should be set to Serial Rx.

    Is there another connection from the X8R that I am supposed to make to maybe one of the UARTs on the Lux-lite? I just have the 3 SBUS connections made. Some guides online say to connect the "Rx" from the receiver to one of the UARTs, then to configure that UART port in cleanflight for serial RX. This confuses me somewhat because I do not see an Rx from my receiver.

    Because I cannot find any good documentation on my ESCs (420 lites), I started trying all of the different ESC protocols. I eventually found one called multishot when using beta flight that actually does result in my motors beeping constantly. I'm not sure what the protocol differences are, but does multishot sound right for a 420 lite?

    Lastly, what is the arming procedure in general? I've been having a hard time finding anything online that describes how to arm this Lux-lite. There is some information on how to program a switch on the Taranis radio to arm a quad, but I'm not sure what the arming procedure for this FC is.

    Any guidance in how to troubleshoot or get this Lux-lite to send commands to the ESCs so I can arm them and calibrate them. I beleive this is the root of the problem. I greatly appreciate any help anybody can provide in answering any of the questions bolded above.
    Last edited by krypter; 23rd July 2016 at 10:52 AM.

  3. #3
    Navigator
    Join Date
    Jul 2016
    Posts
    4
    Click image for larger version. 

Name:	Lux-lite Top2.jpg 
Views:	232 
Size:	223.1 KB 
ID:	73671Click image for larger version. 

Name:	Bottom Side.jpg 
Views:	121 
Size:	248.6 KB 
ID:	73668Click image for larger version. 

Name:	Profile.jpg 
Views:	107 
Size:	223.0 KB 
ID:	73669Click image for larger version. 

Name:	X8R.jpg 
Views:	514 
Size:	256.2 KB 
ID:	73667Click image for larger version. 

Name:	ESC.jpg 
Views:	128 
Size:	199.5 KB 
ID:	73670

  4. #4
    Navigator
    Join Date
    Jul 2016
    Posts
    4
    I will update the status in case anybody else experiences this trouble and ends up here in their search for an answer -- I'll share what I'd found.

    After what feels like an eternity of reading and scavenging the internet, I ended up resolving this. The problem was the ESC protocol set in Cleanflight. For some reason, it defaulted to oneshot. After reading the ESC 420 lite spec sheet (I believe this is referred to as the E305 series), I noticed they receive PWM. I changed the protocol from oneshot to to PWM -- now the ESCs fire up fine.

    I also eventually learned from a youtube video that in order for the X8R to communicate with the Lux-lite, first the cleanflight/betaflight port UART1 needs to be set to serial RX. This would not work at first, as I'd save and reboot but it would revert back to unchecking serial RX. After hours more of reading, I reflashed the firmware with the Lux-Race firmware found on the betaflight github -- using betaflight instead of cleanflight.

    Afterwards, once I set the UART1 port to communicate through Serial Rx, everything was golden.

    I also learned that arming is set in betaflight, and associated a switch on the Taranis. After "binding" a switch on the Taranis radio to Arm in betaflight, this solved that riddle. Simple, but for some reason was not intuitive for me to get to the answer (at least not in a reasonable amount of time).

    I thought I was ready to fly, but when I first went to take off - the helicopter flipped immediately. If you encounter this as a newbie, type into google "flip + takeoff", which yielded many insightful posts. I still am having this trouble, despite verifying the propellers are installed on the correct motors, the motors are spinning in the correct direction, and in betaflight manual mode -- I test each motor 1 at a time and verified the motors are correctly assigned 1,2,3,4 accordingly. I have the yaw rotated -90 because the Lux arrow on the Lux-lite PCB is rotated -90 in relation to the front of the X-quad. I also have betaflight set to X-quad (not Quad).

    Actions I still have to take to try to resolve the flipping on takeoff dilemma are:
    -Adjust trims on the Taranis to never output a stick command outside the range of 1000 - 2000. I noticed the commands go slightly over and under. I've heard FC's can act sporadic if trims aren't set properly.
    -Adjust low end throttle trim to try to raise the engine idle so all the motors start at the same time? This seems like a legitimate way to raise the engine idle speed.
    -Reinforce the Lux-lite using standoffs instead of this garbage velcro provided with the F450 kit. The FC moves when connecting and disconnecting the USB making the accelerometer calibration inconveniently drift when disconnecting and connecting the USB.
    -Reflow ESC connections to the Lux-lite. Possible cold soldering/intermittent connection on a motor.

    Hopefully one of these steps resolves the immediate flip on takeoff.
    Last edited by krypter; 27th July 2016 at 07:14 PM.

Similar Threads

  1. FrSky SBus to CPPM converter
    By Hughie in forum FAQs
    Replies: 2
    Last Post: 23rd June 2015, 02:45 AM
  2. Frsky SBUS to CPPM converter
    By 33db in forum ImmersionRC
    Replies: 4
    Last Post: 27th May 2015, 05:28 PM
  3. Replies: 2
    Last Post: 10th September 2014, 02:33 AM
  4. FrSky X8R & SBUS to CPPM Converter
    By criccio in forum RC TECH
    Replies: 5
    Last Post: 28th August 2014, 11:45 AM
  5. Frsky Taranis X8R Sbus Naza, help!
    By Cannotfly in forum OSDs & Flight Controllers
    Replies: 22
    Last Post: 19th March 2014, 08:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •