Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Fpv mudskipper not working with battery

  1. #1
    Navigator
    Join Date
    Dec 2015
    Posts
    15

    Fpv mudskipper not working with battery

    Hey I got this mudskipper and downloaded clean flight and set up the rx all seems to work properly till I try and calibrate the ESC. No beeps when I plug in battery. Even when I disconnect from computer and put battery in there is no power to the rx. Hook up to the pc and rx gets power but nothing to esc or motor with battery. When I first plugged battery in I got some beeping but ever since nothing, starting to think there is a bad solder joint or I messed something up on the cf setup, but I have dumped everything and ran the info provided from rmrc to the cli and it reboots no problem with the same issue. Happy holidays to all for mine is a little sad, lol. PS I also reflashed the cf to 1.11.0 if this may be the issue?

  2. #2
    FPV Techanic RonSII's Avatar
    Join Date
    Dec 2011
    Location
    PNW USA
    Posts
    3,415
    Are you sure the battery has a full charge? also what king of test equipment do you have? multimeter,scope, extra parts like rx tx etc...

  3. #3
    Navigator
    Join Date
    Dec 2015
    Posts
    15
    The batteries are charged and I have a battery tester. Don't know what a scope is but I took the rx and put in on the vortex and everything is fine when I'm hooked to the cf on pc the sat is fine, all channels read through correctly, got all my end points between 1000-2000. I took the bottom plate off and all solder joints look solid. I use this dx6 with twelve other craft no problem. I think once we can figure out why there is no power to the esc's and sat with battery installed the rest should fall into place. But when in cf everything reacts as should, channel ranges are good, there motors show they work when armed on cf but not with battery.

  4. #4
    FPV Techanic RonSII's Avatar
    Join Date
    Dec 2011
    Location
    PNW USA
    Posts
    3,415
    The reason I asked about the battery was you mentioned it beeped at first... the esc's should always give some kind of indication at power up, since the lipo is charged this would lead me to believe that there is an issue with power getting to the esc's??? check connections and plugs again, would it be possible for you to post up some pics of the craft?

  5. #5
    Navigator
    Join Date
    Dec 2015
    Posts
    15
    i cant load images on here, you got a email or cell number, sorry to be personal i just dont know how else to get the pics to you. says upload of file failed, no reason. lol got to love the holidays.

  6. #6
    FPV Techanic RonSII's Avatar
    Join Date
    Dec 2011
    Location
    PNW USA
    Posts
    3,415
    If your pics are too big( size X,Y or Kbytes) if will error out, I forget the limit but I think it;s around 1280x1080y, 800K or something like that... I use an imgur.com account for big pics( I think photobucket.com and any of the other free sites work also). you say you have a battery tester... you mean with wire leads on it? or a lipo tester with just a plug on it? the reason I ask is to troubleshoot this proper you really need at least a digital multimeter (DMM) otherwise it really limits how much you can test versus just swapping thing out and checking connections/plugs

  7. #7
    Navigator
    Join Date
    Dec 2015
    Posts
    15
    I've got a multi meter as well, I know in clean flight on the battery monitor with USB it's around five volts and with battery only 6-7 volts. That same battery will run my vortex no problem. I handed five different batteries that do the same thing. But I am with you I don't think the ESC are getting the proper voltage but I know the battery is not the culprit.

  8. #8

  9. #9

  10. #10

Similar Threads

  1. Vortex not working, only beeping when I plug battery in
    By davidwanj in forum ImmersionRC Support
    Replies: 1
    Last Post: 19th December 2015, 01:44 PM
  2. Replies: 4
    Last Post: 6th December 2015, 06:31 PM
  3. Replies: 5
    Last Post: 18th December 2014, 02:29 PM
  4. How long on Futaba 8FG internal battery (7.2V Nimh 1800 mAh battery) and EzUHF
    By DiscoTuna in forum Power Regulation / Power Distribution
    Replies: 3
    Last Post: 9th October 2013, 02:01 PM
  5. Replies: 1
    Last Post: 28th August 2013, 06:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •