image
Results 1 to 4 of 4

Thread: MAVLink OSD and MinimOSD v1.1 - Flash to MWOSD v1.3

  1. #1

    MAVLink OSD and MinimOSD v1.1 - Flash to MWOSD v1.3

    Ok after days and weeks of testing etc I finally got my OSD working. Problems I was having was not being able to flash the Arduino on the OSD boards and OSD was not being overlayed.


    To flash your MAVLink OSD and your MinimOSD v1.1 with an Arduino Uno you need to connect it like the following (I would suggest removing the Arduino chip on the Arduino Uno board if you don't want it flashed too):
    Arduino Uno - OSD Board
    RESET - GRN
    5V - +5V
    GND - BLK
    GND - GND
    TXD - TXD
    RXD - RXD


    Yes the TXD and RXD listed above is correct. In fact this was my problem all along; but I thought I had tested it this way before. Then go to the following:
    https://code.google.com/p/multiwii-osd/ or their new location at https://github.com/ShikOfTheRa/scarab-osd


    Download the latest version and in my case it was MWOSD v1.3 listed under the software section (the firmware and software are bundled). Unzip the files into a folder and then load your Arduino software. Open up the sketch MWOSD and compile and upload it. After it is uploaded close out your Arduino software and now open the MWOSD GUI. Before connecting to the board you now need to power up the OSD side of the board. To do this you need to supply power (12V preferred but don't do that if you have modified your board IE an older version of the board where the linear voltage regulator was known for overheating thus the reason for the 5V only mod; new versions of the board you no longer need to do this mod for they are now using switching voltage regulators) to the OSD side; the easy way I found was to just plug in your camera IN and your video OUT (or what ever one that is supplying the power) and your should have two red lights on now instead of one like before. Now select the COM port (in the GUI) to connect to your board; once connected load the fonts and then upload the fonts. After that is completed then disconnect in the GUI and unplug power from the OSD side of the board. Select the correct com port in the GUI and reconnect with your board. You now can then configure the board and your OSD how you see fit. After all is said and done you can unplug everything and plug everything back into your quadcopter. Good to go? Hopefully but not in my case...


    After I did that on both a MAVLink OSD and MinimOSD v1.1 board my OSD overlay display was no longer working. Before my MAVLink OSD had ArduCAM OSD v2.0 and MinimOSD v1.1 had ArduCAM OSD 2.1 and I know this because I hooked them up in my quadcopter and I would see the video and overlay just fine and it would eventually end on waiting for heartbeat. Waiting for heart beat?!?! Well I did not know at the time but Arducam OSD uses a different protocol for communications than Multiwii (which is MWOSD) and Multiwii's protocol works with Naze32 where the other does not. Ok back on track... So I know that my OSD chip was working properly for it was displaying just fine before but with the wrong firmware installed and after installing MWOSD v1.3 (also tried v1.2) I now get video but no overlay. After a LOT of testing I found that if I unplug my camera the OSD works great without any video but once that camera is plugged in it stops. I did some research and found that some have had the same issue but no one could figure out why. I then installed my new Sony EFFIO-V WDR Camera and what do you know everything now works for I get video and OSD. It appears that there is a bug or some kind of issue with MWOSD's firmware which I have submitted to them about. I know it is an issue with their firmware for the OSD did work before with ArduCAM and my old camera but not with MWOSD and my old camera, I figured I would post this for I've been banging my head on these problems for days / weeks and finally got things going and figured I'd help someone else out there that might be having similar issues.

  2. #2
    Navigator slappomatt's Avatar
    Join Date
    Jun 2014
    Location
    San Diego, CA.
    Posts
    576
    I have always used an FTDI adapter to flash my minim 1.1. once I figured out that I had to flash the mwosd FW on the minim with arduino software and had the arduino software configured for the right board (nano) and the right com port it worked great. cost about half or less than what a uno cost ( although I have one of those now too for flashing my bear hug esc ( at least unill they crap out on my which is pretty inevitable from what I hear about them))

  3. #3
    I have the same problems, have anybody solved this issue?

    What other FW do you use on minimosd v1.1?

  4. #4
    Quote Originally Posted by OrangePower View Post
    I have the same problems, have anybody solved this issue?

    What other FW do you use on minimosd v1.1?
    Hey I eventually got a FTDI programmer; this exact one: http://www.multirotorsuperstore.com/...in-3-3-5v.html and it just made things much easier and quick. You can use to on many other things too so it's cheap for what you can do with it. Using the Arduino UNO works but is kind of a pain especially after I got this tool.

Similar Threads

  1. Replies: 4035
    Last Post: 19th July 2019, 09:00 AM
  2. NAZE32 GPS, MWOSD, FrSKY Telemetry HELP !!
    By PIKE408 in forum OSDs & Flight Controllers
    Replies: 1
    Last Post: 16th January 2015, 06:39 AM
  3. Mavlink/Minimosd & apm 2.5 current/volt sensor
    By Xerx in forum OSDs & Flight Controllers
    Replies: 1
    Last Post: 7th February 2014, 01:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •