Results 1 to 4 of 4

Thread: Mk2-L Carbon arms QC issue?

  1. #1
    Navigator
    Join Date
    Nov 2014
    Posts
    14

    Unhappy Mk2-L Carbon arms QC issue?

    Hi all,

    I got the frame for my Mk2-L tank from ReadyMadeRC a few weeks back and I only now have some time to put everything together with parts I sourced from various places. So far so good until I reached the stage where I need to fit the plastic clamps to the carbon tubes (which isn't far ahead yet so hopefully this will be my only hurdle).

    This is where I encountered two problems related to the quality control of the carbon tubes and possibly the plastic clamps as well.

    First problem:
    The holes in the carbon tubes for the plastic clamps to fit in and lock in place are too small so the plastic clamps couldn't sit flush to the tubes no matter how much pressure I put trying to push them together (within reason of course.. I don't want to accidentally break the tubes after all, but my hands still hurt if that's any indication). This also means the medium-length screws I'm supposed to use for this part couldn't reach through to catch on to the hex nuts at the other side.

    I figured that's not a big issue, I can just file them and that does work, but it is very annoying and time consuming that I would have to do it for each and every hole on each and every tube I received in my kit.


    Second problem:
    This is the major one and it has practically stopped me from progressing any further in my build

    The holes that were drilled into the tubes for those plastic clamps to lock on to were drilled off-center. No single tube had both ends of the holes perfectly centered, and this means I couldn't align the plastic clamps either. I don't think I could just file one side of the hole as that might cause issues with the rigidity of the motor placement once the whole thing is built-up.

    Anyway, just in case my explanation isn't clear, here's a couple of pictures to illustrate my point:

    Click image for larger version. 

Name:	image1.jpg 
Views:	132 
Size:	94.7 KB 
ID:	57691 Click image for larger version. 

Name:	image2.jpg 
Views:	133 
Size:	139.7 KB 
ID:	57690

    So now.. I'm wondering if anyone has had similar problems and if so, how can this be resolved? Would FlyingCinema be willing to send me replacement tubes, for instance, or would I have to shell out extra money to buy replacement tubes which may or may not have these same issues?

    I was pretty impressed with the professional nature of the packaging but now these problems come along to spoil things.

  2. #2
    Navigator
    Join Date
    Aug 2014
    Posts
    320
    Drop a note to FC's support email address.

    I had a similar issue and had an excellent experience with David's speedy response.

  3. #3
    flyingcinema.com bllama's Avatar
    Join Date
    May 2013
    Location
    South Florida, US
    Posts
    769
    Taken care off, will ship out first thing this Monday.

  4. #4
    Navigator
    Join Date
    Nov 2014
    Posts
    14
    Much appreciated for the support!
    Can't wait to get back to building my tank.

Similar Threads

  1. G10 arms
    By airmikeyy in forum LUMENIER Support
    Replies: 14
    Last Post: 1st February 2014, 11:39 PM
  2. TBS Arms or DJI F450 Arms??? Confused.com!!!
    By Hally1983 in forum Team-Black Sheep
    Replies: 3
    Last Post: 15th January 2014, 06:18 PM
  3. G10 extended arms
    By airmikeyy in forum LUMENIER
    Replies: 16
    Last Post: 4th October 2013, 12:54 PM
  4. New Motors & ESC issue and drift issue on Disco
    By sl4ppy in forum Team-Black Sheep
    Replies: 9
    Last Post: 24th November 2012, 04:35 AM
  5. Throttle not working till 50% issue (ESC to EZUHF issue)
    By SinaAzmoudeh86 in forum ImmersionRC
    Replies: 35
    Last Post: 28th May 2012, 05:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •