image
Page 356 of 405 FirstFirst ... 256306346354355356357358366 ... LastLast
Results 3,551 to 3,560 of 4041

Thread: MWOSD - for BETAFLIGHT CLEANFLIGHT RACEFLIGHT PIXHAWK KISS DRONIN INAV and others

  1. #3551
    Pilot
    Join Date
    May 2011
    Posts
    1,139
    How is if connected? - if to the FC, Do you have "use FC" set?
    Click image for larger version. 

Name:	Capture.PNG 
Views:	27 
Size:	1.9 KB 
ID:	77018

    Quote Originally Posted by ShortnStubby View Post
    Thank you, I tried pretty much everything and tons of google searching, my hardware is as follows holybro pdb osd 1.2 and a sp racing f3. the voltage I have working by flashing the aeromax hardware setting, using minimosd just sets voltage to 16.3 but this could be that aeromax reads voltage from the pdb and minim reads from fc? I have not dug though code to try and figure out how this all interfaces. The amps how ever if I leave uart unplugged I get reading somewhere in 14-15 ish range never moves then plug uart in and reset, it reads 0.0 which is why I assumed it as just trying to query a bad variable.

    Thanks again, great work.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Capture.PNG 
Views:	25 
Size:	1.4 KB 
ID:	77017  
    *** Still flying up my own arse ***

  2. #3552
    Pilot
    Join Date
    May 2011
    Posts
    1,139
    Yes - providing it uses ublox, nmea or MTK protocol. Need to figure out which and what baud rate. I would say 95% chance it will

    Quote Originally Posted by thehelidude View Post
    I have a small plane that uses a ublox gps and a propriety flight controller. Might it be possible to share the gps with the flight controller and use mwosd standalone to read the data coming out of the gps tx wire or is the connection between mwosd and gps a 2 way communication?

    The plane:
    https://www.horizonhobby.com/product...-s-bnf-hbz5480
    *** Still flying up my own arse ***

  3. #3553
    Pilot
    Join Date
    May 2011
    Posts
    1,139
    I have just updated the main repository with revised channel ordering for APM and PIXHAWK. It will be in next main release.
    Can use Arduino to upload. or download relevant hex from here and use new GUI "flash from disk": https://github.com/ShikOfTheRa/scara...es/tag/1.7.1.1


    Quote Originally Posted by rank View Post
    I have just purchased the Chrome Gui, uploaded the latest firmware to the osd, connected to Pixhawk and noticed the "bug" from the older firmware still there.
    This is concerning the Throttle position indicator, since my throttle is on the 3rd channel and Rudder is on 4th, I get the rudder position indication, instead of the throttle.
    I was able to change it within the file before, but, since the new Gui is pulling the latest version automatically, I'm not able to change it now.
    I have checked all over the Gui settings, and could not find the option to change the radio settings.
    *** Still flying up my own arse ***

  4. #3554
    Pilot
    Join Date
    May 2011
    Posts
    1,139
    Wayno - can't see the file. says unavailable. Im leaving shortly for a few days - back friday so apologies if don't reply.

    Quote Originally Posted by Wayno View Post
    Shikra, heres a video of the Pixhawk starting up. Timers work as should. Altitude reads 0 until armed, then when armed changes to ASL.

    *** Still flying up my own arse ***

  5. #3555
    Navigator
    Join Date
    Feb 2012
    Location
    Milton Keynes, UK
    Posts
    107
    Ah, changes to unlisted. Doh.

    No rush mate.

  6. #3556
    Navigator
    Join Date
    May 2017
    Posts
    4
    Quote Originally Posted by shikra View Post
    What OS,
    Are you connecting direct or using passthrough service on FC
    Passthrough service on fc but had the same issues with direct connecting.

  7. #3557
    Navigator
    Join Date
    May 2017
    Posts
    4
    Quote Originally Posted by shikra View Post
    What OS,
    Are you connecting direct or using passthrough service on FC
    I know with cheap boards I have to direct connect but that's not the case. Do I have to cheange sth. here in the com port settings in the hardware device manager?
    I tried selecting all of the different bauth rates in the mwosd configurator but it doens't work unfortunately.
    Thanks in advance
    Click image for larger version. 

Name:	Screenshot (227).png 
Views:	44 
Size:	49.6 KB 
ID:	77019

  8. #3558
    Navigator
    Join Date
    Feb 2015
    Posts
    8
    Is MWOSD compatible with Pixhawk 2.1 and Pixracer boards? I can't seem to get the altitude to display correctly, I get like 800+ feet for altitude.

    I tried to change the config.h file to sue baro but no luck. This is driving me insane and can't get it to work. To include volts and amperage don't display correctly. The volts fluctuate and the amps don't move when I apply amperage to the motors.

    Please help!

    Ben

  9. #3559
    Navigator
    Join Date
    Feb 2012
    Location
    Milton Keynes, UK
    Posts
    107
    Does your altitude work out to be above sea level by any chance? That's what mine is doing on pixhawk.

    Shikra is looking into this already but is away for the next few days.

  10. #3560
    Navigator
    Join Date
    Feb 2015
    Posts
    8
    Wayno,
    Thanks for the update... I believe it is. Right now it's around 240+. Is your voltage and amperage correct and if so, how did you manage to fix?

    Ben

Page 356 of 405 FirstFirst ... 256306346354355356357358366 ... LastLast

Similar Threads

  1. Why won't baseflight connect on my Mac ?
    By Sortie72 in forum OSDs & Flight Controllers
    Replies: 45
    Last Post: 24th November 2015, 02:14 AM
  2. TBS DiscoPro + MultiWii (Baseflight on Naze32) PID regulation
    By Asurendra in forum OSDs & Flight Controllers
    Replies: 10
    Last Post: 7th January 2015, 02:41 PM
  3. 400Q Specific Baseflight firmware for Naze32
    By chatch in forum REALFPV.COM
    Replies: 72
    Last Post: 29th April 2014, 08:41 AM
  4. HELP GUYS LIKE ME THAT REALLY WANT TO CROSS OVER TO NAZE32/MULTIWII
    By Bigjack in forum OSDs & Flight Controllers
    Replies: 28
    Last Post: 28th February 2014, 02:22 AM
  5. need help multiwii pro
    By florinb31 in forum OSDs & Flight Controllers
    Replies: 2
    Last Post: 23rd May 2013, 12:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •