Page 3 of 11 FirstFirst 12345 ... LastLast
Results 21 to 30 of 109

Thread: Skylark Tiny OSD III - Nightrams comprehensive page

  1. #21
    Navigator
    Join Date
    Oct 2013
    Location
    Tennessee
    Posts
    7
    Hi, I have a problem with connecting Skylark Tiny OSD III to my Windows 7 laptop. Can someone please advise?

    1) I go to Skylark website here and download Skylark config program and latest firmware:
    http://www.skylarkfpv.com/download/s...ation_tool.zip
    http://www.skylarkfpv.com/download/Tiny_III_V2.9.zip


    2) I plug in USB cable to the GPS port, and plug in to the computer. Even though I already installed prollific driver, my Windows 7 laptop searches on Windows Update, and installs the driver OK


    3) I run the Skylark config program. I can see that it says Prolific USB-to-Serial Comm Port COM4 in the bottom right corner and at the top. I see "Disconnect" button at the top, so I think it is connected.


    4) When I click on Imperial(Mph) and then Set. Nothing happens.


    5) When I click on Upgrade, and browse to the file Tiny_III_V2.9.bin that I downloaded from Skylark website, and then I click Upgrade. Nothing happens.


    6) I wait 5 minutes, to see if it is going to do something.


    7) I close the Skylark program, and then run it again.


    8) I see it still has Metric for unit, not Imperial(Mph) that I want



    Even though it seems to connect to the Skylark FPV on COM4, the software does not do anything. I can't flash a new firmware or set any settings.


    For this I am not using 5V power with the OSD. I just plug it into the provided cable that goes to USB. I made sure it is the GPS port (not the current sensor port)


    Please help. I wrote email to Skylark on service@skylarkfpv.com and sales@skylarkfpv.com and didn't receive any reply.

  2. #22
    Hive Mind Nightram's Avatar
    Join Date
    Sep 2013
    Location
    Adelaide, Australia
    Posts
    1,210
    Quote Originally Posted by Hdogger View Post
    Hi, I have a problem with connecting Skylark Tiny OSD III to my Windows 7 laptop. Can someone please advise?

    1) I go to Skylark website here and download Skylark config program and latest firmware:
    http://www.skylarkfpv.com/download/s...ation_tool.zip
    http://www.skylarkfpv.com/download/Tiny_III_V2.9.zip


    2) I plug in USB cable to the GPS port, and plug in to the computer. Even though I already installed prollific driver, my Windows 7 laptop searches on Windows Update, and installs the driver OK


    3) I run the Skylark config program. I can see that it says Prolific USB-to-Serial Comm Port COM4 in the bottom right corner and at the top. I see "Disconnect" button at the top, so I think it is connected.


    4) When I click on Imperial(Mph) and then Set. Nothing happens.


    5) When I click on Upgrade, and browse to the file Tiny_III_V2.9.bin that I downloaded from Skylark website, and then I click Upgrade. Nothing happens.


    6) I wait 5 minutes, to see if it is going to do something.


    7) I close the Skylark program, and then run it again.


    8) I see it still has Metric for unit, not Imperial(Mph) that I want



    Even though it seems to connect to the Skylark FPV on COM4, the software does not do anything. I can't flash a new firmware or set any settings.


    For this I am not using 5V power with the OSD. I just plug it into the provided cable that goes to USB. I made sure it is the GPS port (not the current sensor port)


    Please help. I wrote email to Skylark on service@skylarkfpv.com and sales@skylarkfpv.com and didn't receive any reply.
    Did you follow the guide in the first post to the letter and use the driver I supplied?

  3. #23
    Navigator
    Join Date
    Oct 2013
    Location
    Tennessee
    Posts
    7
    Quote Originally Posted by nightram View Post
    Did you follow the guide in the first post to the letter and use the driver I supplied?
    Thanks for your reply. Which driver are you referring to? The Prolific driver for the cable? The first post does not have a link to the Prolific driver. I did a Prolific driver link in your 2nd post in this thread, but that link is no longer valid. It just goes to an index view of your Onedrive. I see another Prolific driver listed there "Profilic_Win8_x64_x86". Should I use that?

    I had previously tried installing the Prolific driver directly from Prolific. It installed ok. But then when I plug in the Tiny OSD III, Windows searches Windows Update anyway and installs that driver.

    I have Windows 10 laptop and a Windows 7 laptop available. Is it possible these days to use my Windows 10 laptop? I have previously only been using my Windows 7 laptop, but it appears the driver in your OneDrive is targeted to Windows 8 so it might work with Windows 10.

    Thanks for any more advice you could provide.

  4. #24
    Hive Mind Nightram's Avatar
    Join Date
    Sep 2013
    Location
    Adelaide, Australia
    Posts
    1,210
    Quote Originally Posted by Hdogger View Post
    I see another Prolific driver listed there "Profilic_Win8_x64_x86". Should I use that?.
    Yes, that is the one to use. It is the '07 (I think) version that is compatible. Also there are two usb adaptors, although I don't know of any actual difference that may be a factor.

  5. #25
    Navigator
    Join Date
    Oct 2013
    Location
    Tennessee
    Posts
    7
    Quote Originally Posted by nightram View Post
    Yes, that is the one to use. It is the '07 (I think) version that is compatible. Also there are two usb adaptors, although I don't know of any actual difference that may be a factor.
    Yes. I have followed the directions to the letter. I used the Prolific driver in your Onedrive, and found this web page with directions on how to install it. I followed them to the letter also.
    http://ananddrs.com/2014/09/24/pl230...r-windows-8-1/

    I just this morning, downloaded a fresh copy of the config tool and the firmware from Skylark website.

    When I run the config tool, it is the same experience as before. It says "Prolific USB-to-Serial Comm Port (COM3) COM3" on the bottom of the config tool. I see a "Disconnect" button at the top. So, it thinks it is connected.

    When I click "Imperial(Mph)" and then Set. Nothing happens.

    When I go to Upgrade tab, browse to the new .bin file, and click Upgrade button. Nothing happens.

    When I quit, and re-run the config tool. I see that it is still set to the default "Metric" unit, instead of Imperial that I previously selected.

    I can see in Device Manager, the port is fine. Under Ports (COM & LPT) I have an entry that says Prolific USB-to-Serial Comm Port (COM3). It does not have any yellow mark. It is working ok according to Device Manager. I think the cable is not the problem.

    Thanks for your help!

  6. #26
    Hive Mind Nightram's Avatar
    Join Date
    Sep 2013
    Location
    Adelaide, Australia
    Posts
    1,210
    Is the osd powered while you do this?

  7. #27
    Navigator
    Join Date
    Oct 2013
    Location
    Tennessee
    Posts
    7
    No. It is only connected to the computer via the USB cable that came with it. I triple checked and it is going into the GPS port. I don't have the OSD hooked to anything else.

  8. #28
    Navigator
    Join Date
    Oct 2013
    Location
    Tennessee
    Posts
    7
    Hi, just wanted to follow up. I didn't get any other reply. Was it correct that the OSD should not be powered while doing this process?
    What else can I try, to get it to flash?
    Thanks!

  9. #29
    Navigator Qrome's Avatar
    Join Date
    Nov 2011
    Posts
    48
    Hey guys, I love this OSD and have 4 of them running. Me and a buddy just bought 2 more from BangGood the only problem is neither of them will detect the GPS. I have tested the main module with my other GPS and they show up. Also, when booting the firmware on the module says Tiny OSD III v3.0 -- I don't see the v3.0 for download anywhere. Just wondering if these GPS units are bad or if they might be configured for the wrong baud rate. Thanks!

  10. #30
    Navigator
    Join Date
    Apr 2012
    Posts
    657
    The v3.0 firmware only changes are, gps info in simple screen
    So it couldnt give you any problem with the gps
    Does the new gps work on your other osds?
    If not it looks like the gps is not configured correctly like you were thinking already
    I would say RMA

Similar Threads

  1. Skylark Tiny Osd III with 6s
    By Norse in forum SkylarkFPV
    Replies: 22
    Last Post: 4th January 2015, 04:24 AM
  2. Comprehensive Tiny OSD III wiring diagram
    By OBwan in forum SkylarkFPV
    Replies: 8
    Last Post: 15th December 2013, 10:00 PM
  3. Help with Skylark Tiny OSD
    By gobigdale in forum SkylarkFPV
    Replies: 4
    Last Post: 19th October 2013, 01:00 AM
  4. Help with Skylark tiny osd
    By bigmoebbq in forum IFR - Video Link Discussion
    Replies: 7
    Last Post: 18th November 2011, 09:55 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •