Results 1 to 10 of 10

Thread: Skylark Trace not working on Firmware 2.9

  1. #1
    Pilot gobigdale's Avatar
    Join Date
    Sep 2012
    Location
    Gig Harbor, WA
    Posts
    1,105

    Skylark Trace not working on Firmware 2.9

    Just got a brand new Trace from RMRC and got it wired up last night. Connected it to the PC and updated the firmware to the 2.9 found on this page:

    http://www.skylarkfpv.com/en/down.php?CateId=3
    I have video, but no OSD shows up. Please help.

    Dale

  2. #2
    You may download a wrong firmware for Trace.

    If you download a Tiny OSD firmware for Trace, this problem will be to occur.

    Please check if the OSD can connect with Skylark software.
    If so, please try update the Trace firmware for your OSD again.
    http://www.skylarkfpv.com/download/Trace_OSD_V2.9.zip
    Skylark FPV Service Center
    http://www.skylarkfpv.com

  3. #3
    I am having the same problem, and I believe I did use the tiny OSD firmware on my Trace OSD, What can I do at this point? I can not get it to connect to the software anymore?

    thanks,

    Chris.

  4. #4
    Hello skylark,

    I mailed my trace OSD to you as instructed on may21st. I have sent emails, inquiring about it...??? Any news?

  5. #5
    Hi guys,
    I had ordered and received the skylark trace and installed it yesterday on my qx350. It was great until I updated the firmware to the 2.9 version this evening. It went through the install perfectly and said it had installed 52 packets and the red LED light on the board went out. I hit the disconnect button and reinstalled it to the quad......then.. I got nothing... well the gps lights up but the main board LED lights don't light up. No video...no nothing. Just a black screen in my Fatshark goggles (yes i remembered to remove the lens cover for the camera..lol). When I remove the OSD and plug the camera directly in the transmitter I get video but with the ODS hooked up..I get nothing.
    So removed it from the quad and hooked it back up to the PC. It recognizes the usb and says its connected but no LED like when I first hooked it up. It doesn't do anything when I tried to update the firmware again or hit the read buttons...still no response.
    I even hit the reset button thinking that might help.... the LED will try to illuminate as you release the button for a micro second but has no effect. So I think the firmware upgrade did something to lock it up? Have you had this issue reported before and were able to fix it?
    Please help if you can.
    Thank you,
    Martin

  6. #6
    I just got a response email about my osd that I sent to skylark....3 months ago. They never received it. I'm done with this company.

  7. #7
    I have the same problems hat other users, I was wrong with the firmware. I can no more access to the OSD from the PC. I have sent mail and did not answer. It has a solution or throw it away? thank you!

  8. #8
    Click image for larger version. 

Name:	IMG_20151128_171333.jpg 
Views:	101 
Size:	167.4 KB 
ID:	68370Click image for larger version. 

Name:	IMG_20151130_090042.jpg 
Views:	102 
Size:	134.0 KB 
ID:	68371
    Please follow the steps
    1. Please connect the two hole
    2. Connect the Trace OSD with your battery or USB cable.
    3. Disconnnect the two hole
    4. Connect the Skylark USB cable, the try to update the firmware again.
    Skylark FPV Service Center
    http://www.skylarkfpv.com

  9. #9
    Thank you for your help! But it's the same! I cant get comunication with OSD.
    Any other idea?
    thank you!

  10. #10
    Hi
    ive just received my Trace OSD today in the mail video is fine on a PAL camera but no OSD ????

Similar Threads

  1. Replies: 1772
    Last Post: 25th January 2019, 02:46 AM
  2. Skylark Trace OSD issues
    By Goody63 in forum SkylarkFPV
    Replies: 3
    Last Post: 21st October 2013, 06:14 AM
  3. Skylark Trace IV
    By Reverand Blue Chip in forum SkylarkFPV
    Replies: 15
    Last Post: 25th August 2013, 04:28 PM
  4. Anyway to run a Skylark Tiny or Trace OSD on 2s?
    By Howemd in forum SkylarkFPV
    Replies: 1
    Last Post: 21st June 2013, 02:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •