Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Nothing but white screens.

  1. #21
    Navigator 34Ford's Avatar
    Join Date
    Jan 2014
    Location
    North Carolina
    Posts
    231
    Its getting late so I will do more checking tomorrow. Seems like I have to have a audio cable hooked up as well to get a good video.

    Acts like a bad ground on the yellow plug. Anyway, thanks and goodnight.
    Dennis
    TBS Discovery Pro w/Vector and Typhoon Q500 4K

  2. #22
    Navigator 34Ford's Avatar
    Join Date
    Jan 2014
    Location
    North Carolina
    Posts
    231
    Well I was right. The yellow rca plug is not supplying a ground. I can jump any of the other plugs grounds with a test wire with alligator clips and wow, look at that sweet video. Maybe its the jack in the goggles.


    EDIT: Nope found it. A short in the yellow plug.
    Last edited by 34Ford; 11th June 2014 at 07:20 PM. Reason: found it
    Dennis
    TBS Discovery Pro w/Vector and Typhoon Q500 4K

  3. #23
    Fatshark AU/NZ Repairs hpcoolahan's Avatar
    Join Date
    Nov 2011
    Location
    Yamba nsw...Australia
    Posts
    5,611
    That's a bummer with the cable , seeing as you have dealt with Zoltan at www.nghobbies.com before , he has new cables here https://www.nghobbies.com/cart/index...ort=20a&page=4

    The cable might have been kinked or pulled on when connected before , and has caused the cable issue.
    Australia post: "delivering packages the day after you need them since 1809"

    "Light travels faster than sound -- thats why some people appear bright until you hear them speak" - Albert Einstein.

Similar Threads

  1. Where I Can buy Predator V2 LCD Screens ??
    By jcclfzr in forum Fatshark Support
    Replies: 5
    Last Post: 3rd March 2014, 03:45 PM
  2. LCD screens. Why use 16:9, wouldn't 4:3 be better?
    By Byro in forum Ground Stations...
    Replies: 2
    Last Post: 27th November 2013, 06:24 AM
  3. Screens, what to buy?
    By PeteDee in forum Ground Stations...
    Replies: 27
    Last Post: 6th July 2013, 03:19 PM
  4. Base SD goggles stopped working (white / coloured flashes on screens)
    By SlipstreamFPV in forum Fat Shark R/C Vision Systems
    Replies: 2
    Last Post: 20th May 2013, 11:12 PM
  5. Where did all the cheap screens go?
    By squishy in forum IFR - Video Link Discussion
    Replies: 42
    Last Post: 13th December 2012, 02:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •