So I was tinkering with my beater wing with a Trace II OSD in it, and decided to try to update the firmware from v1.7 to 2.8. The software reported a successful update, so i disconnected it and fired up the plane. Nothing, no lights on the osd and no osd text on screen at all. No startup screen or anything.

So I hook it back up to the usb programmer and restart the skylark software. It connects immediately and starts repeating the message 'begin firmware update' at the bottom. I still had the bin file for v1.7, so i put that one back on and everything is back to normal.

So am I to assume that the newer versions of Trace firmware only work on the later hardware revisions (Trace III, Trace IV) and that they cannot be used on the Trace II?