image

Search:

Type: Posts; User: Ric4nier; Keyword(s):

Search: Search took 0.01 seconds.

  1. Replies
    4,871
    Views
    1,002,483

    I'm fairly new to the tbs crossfire ....have it...

    I'm fairly new to the tbs crossfire ....have it setup in my new dji digital fpv quad. I'm not clear on the setup of the radio, I have nano rec. I just turned off the dynamic power....Is that...
  2. tbs crossfire

    thanks Jan.,,,,I switch to a sbus receiver and having no problem with wizard....
  3. TBS Crossfire not working with Micro Vector

    I can't get crossfire to work with the micro vector....every time I run the wizard, keep saying it doesn't recognize switches, can't go any further with the setup. If anyone has any advice it would...
  4. Thread: TBS VENDETTA

    by Ric4nier
    Replies
    1,536
    Views
    372,511

    I had to send my vendetta back after a long wait...

    I had to send my vendetta back after a long wait for it, very disappointing, lucky the vendor credit my account. My problem with the quad was the motors never could spin.

    The problem I believe is...
  5. Thread: TBS VENDETTA

    by Ric4nier
    Replies
    1,536
    Views
    372,511

    I thought I already did change the call sign with...

    I thought I already did change the call sign with no results.... but thanks for your help,I do appreciate help at this time.... after months of pre ordering from a dealer who I won't mention, to have...
  6. Thread: TBS VENDETTA

    by Ric4nier
    Replies
    1,536
    Views
    372,511

    Another question....how do you unlock video...

    Another question....how do you unlock video transmitter, won't change from 25???

    thanks
  7. Thread: TBS VENDETTA

    by Ric4nier
    Replies
    1,536
    Views
    372,511

    Just got my vendetta yesterday after long...

    Just got my vendetta yesterday after long wait....it's all setup with clean flight and osd, problem I am having is motors don't spin, goggles say armed, but motors don't spin, not sure what to try...
  8. Yes....I am having the same problem....tried just...

    Yes....I am having the same problem....tried just about everything, can't connect!
Results 1 to 8 of 8