image

Search:

Type: Posts; User: SLV; Keyword(s):

Search: Search took 0.07 seconds.

  1. Thread: TX5G6 Pin-Out

    by SLV
    Replies
    2
    Views
    3,233

    Bad advise, at least for me. I found this thread...

    Bad advise, at least for me. I found this thread in a Google search and followed what you said, then wasted my time trying to figure out why I had no video... :)

    The legend printed on the vtx was...
  2. Replies
    7
    Views
    1,737

    sweet got it going! thanks guys.

    sweet got it going! thanks guys.
  3. Replies
    7
    Views
    1,737

    ahh, my RX is on Version: 1.43 and my TX is on...

    ahh, my RX is on Version: 1.43 and my TX is on Version: 1.48

    How do I update the Receiver? When its connected, I go to the program tab and it says 'EzUHF Rx not detected press button and attach to...
  4. Replies
    7
    Views
    1,737

    need help binding EzUHF tx/rx

    Ok so I bought the EzUHF JR module for my 9x radio and I'm having trouble getting it to bind.

    Ive read through the sticky and have done everything the way it says

    I press and hold the bind...
  5. Replies
    1
    Views
    1,341

    Broken Go Pro, bricked from hard crash

    Hello everyone, hopefully someone can help

    My go pro 2 shat itself after a really hard crash, my quad dropped from like 20 meters onto tarmac, the battery flew out on impact while it was...
  6. Replies
    30
    Views
    6,537

    PM sent

    PM sent
  7. Replies
    30
    Views
    6,537

    My new receiver just arrived, I swapped it out...

    My new receiver just arrived, I swapped it out with the on in the fatsharks and still have the same problem, no video on any channel. A couple of the channels have static and lines and the others are...
  8. Replies
    30
    Views
    6,537

    So the NexwaveRF Receiver for the Dominators will...

    So the NexwaveRF Receiver for the Dominators will work ok in the Predators? I will order one and if it works, if not ill send it your way. Cheers for the help
  9. Replies
    30
    Views
    6,537

    They are V1 Predators I opened them up, and...

    They are V1 Predators

    I opened them up, and there was a slightly loose wire connector coming from the RX, I put it back in but they are still not working, so that might have just came loose when I...
  10. Replies
    30
    Views
    6,537

    Fatshark Predator problem, no video only lines

    Hi ive been having trouble getting my FPV setup working

    I had it working for a few months and after a rebuild of my quad, I cant get any picture in my Fatsharks. At first I thought it was the...
Results 1 to 10 of 10