PDA

View Full Version : Dominator HD Head Tracking with Taranis X9D



hkfanatic
29th August 2014, 06:23 PM
Hi, Folks.

I finally got my Dominator HD yesterday and aside from a battery, it came with a head tracker (thank you very much, Fat Shark!).

I tried setting it up with my Taranis and I was able to get the tilt and the roll working by using PPM6 and PPM7, respectively. Unfortunately, I couldn't get the pan to work. I've tried all the other PPMs but nothing worked. I also noticed that PPM5 turns the pan servo all the way to one side.

Your help would be sincerely appreciated. Thanks in advance.


Jimmy

hpcoolahan
29th August 2014, 09:40 PM
Can you try swapping the pan onto tilt or roll that's working on the receiver atm, this will rule out any issue with the head-tracker and the mount ...which leaves something in the radio you need to change.

hkfanatic
30th August 2014, 01:11 AM
Thanks for the prompt reply HP.

I'm just on the road right now and thus can't do the swap but I'm sure the pan servo is working because I mapped it earlier with the left slider and it worked just fine.


Could it be possible that I need to center the servo with the tracker? How do I enter the programming mode anyway?

hpcoolahan
30th August 2014, 01:30 AM
Centering in the HT menu is only for the final small adjustments (fine tuning) .
Really need to confirm that the pan servo is ok first , then figure out what else is going on .
Manual is here BTW http://www.fatshark.com/uploads/pdf/1748-1.pdf
To enter the menu , just hold the HT button down , plug power in , and release button straight away...your then into the menu and need to start counting the beeps to get where you want to go ;)
I'd get into the menu , and re-set it to all defaults ( 6 short beeps) and then start from there.
Make sure you have no mixes going in the radio also.

hkfanatic
30th August 2014, 01:53 AM
Thanks again for the info, HP.

Prior to getting the goggles, tha pan servo was mapped to the left slider and it panned flawlessly that's why I'm confident it's not defective. In fact, if I map it to PPM5, it stll turns except it does all the way to the right then stays there.


Nonetheless, I' still follow your recommendation when I get home and let you know how it "turns" out (pan...err...pun intended). ;)

hkfanatic
30th August 2014, 05:46 AM
Hi, HP.

I tried swapping the pan and the tilt servo at the receiver's ports and the pan servo worked just fine but the camera tilted all the way up.

I tried swapping at the transmitter's programming and the tilt worked fine again but the pan swung all the way to the right.

I tried pressing the HT button then plugged the power in and I heard 3 short beeps. Then the beeps started going through the list in the manual. How do I enter the mode that I want to change?

Could I have a defective head tracker?

hpcoolahan
30th August 2014, 06:03 AM
Don't think there has been a confirmed HT issue yet with the Trinity HT.
It is always been a cable or seating issue, try reseating the HT module .
Check the cable for shorts or damage.

Also make sure you don't have the cable connected to the radio when you power up the goggles, it can affect the calibration of the HT on start-up.
to select anything in the menu , wait for the correct beep sequence and quickly press the HT button to select it.
So wait through the sequence for the 6 short beeps , then press the HT button to select factory re-set.

hkfanatic
30th August 2014, 06:36 AM
Here's the good news, HP: I don't believe the problem is with the HT either. Why? I tried installing a spare HT (I bought 1 in advance, not knowing there will be 1 included) and the result was the same. I put back the HT from the factory and the result was still the same. I therefore suppose it's not a case of bad seating (I carefully seated every time).

My guess was right on the menu (I pressed the HT button when I heard the 6 short beeps then heard 2 long ones (?) ) so I was able to restore for factory default. Problem was still there.

I removed the Fat Shark JR Data cable before I powered up the goggles. 'Got the same results.

I don't suppose it's the transmitter because the pan servo worked when I swapped channel 5 and 6.

hkfanatic
30th August 2014, 07:28 AM
Update:

I thought it might help if we distinguished whether the signal or the "movement" of the goggles is the problem. Up until now, the pan movement of the goggles doesn't seem to reach the servo (only the tilt and the roll movements had an effect on any of the servos).

I switched the Trinity's P/T/R to channels 6, 7, and 8, respectively. Lo and behold, the pan movement had an effect on a servo. The problem is, the tilt servo was affected. I don't know why this is. I checked the servo connections on the receiver and the transmitter and they both correspond to channels 6, 7, and 8.

I hope this helps in the troubleshooting.

hpcoolahan
30th August 2014, 07:47 AM
That pretty much rules out any issue with the HT itself and the cable then .
Got to be an issue in the radio settings somewhere then by the sounds of it.
Go through the settings in the radio again , I know you said earlier on that you had it on a slider , my guess is that theres still something related to a previous set-up that's causing this.

hkfanatic
30th August 2014, 10:57 AM
Hi, HP.

I created a new model just to rule out any remnant programming that's causing the error. Same problem (P/T/R on Channels 5/6/7, no servo movement on pan movement).

I looked at the Channels Monitor page of the Taranis X9D and saw that channel 5 (pan, PPM5) was already on -100 and doesn't change regardless of how much I move the goggles. Channel 6 (tilt, PPM6) and channel 7 (roll, PPM7) on the other hand were showing -100 to +100 signals when the goggles were tilted and rolled, respectively.

Shortly thereafter, the tilt and the roll refused to work as well. Would you have a diagnosis at this point given the above?

kkuhler
30th August 2014, 01:59 PM
Tried attaching the working setup from my Taranis, but could not get the file to attach. If you pm me your email address I will email it to you

hkfanatic
31st August 2014, 12:41 AM
Great news, gentlemen! I was able to finally make the pan work. Thank you for all your help. If you're interested how, read on.

I was confident all 3 servos of the mount were working fine (I mapped them earlier to the sliders/knobs without any problem). I was also confident that my receiver was working (I opened a new X8R just for testing and swapped the servo ports and they worked just fine except for the one mapped to the pan).

I therefore simplified and broke down the whole setup to the goggles and the X9D. I noticed on the Channel Monitor page that my Channel 5, when mapped to PPM5, was always at -100. PPM6 and PPM7 were working just fine. Thus, I tried switching to mode P/T/R on 6/7/8. Finally got the pan to work.

I simplified further and removed the goggles. PPM5 on Channel 5 was still at -100.

I therefore conclude the problem is with the transmitter.

Thanks, everyone!

hkfanatic
31st August 2014, 01:17 AM
I hope I'm not asking too much, but would anyone know why my PPM5 is at -100 all the time?

I checked with my son's X9D and PPM5 worked just fine.

What setting could I have done on my X9D that sets PPM5 at -100?

hpcoolahan
31st August 2014, 06:00 AM
Glad you figured it out , I thought it was something to do with the radio as everything else seamed to check out as working.
Make sure your ch 5 is not still linked to the slider you had it on before.
Generally doing a new model setup will solve most issues , but in this case if it's still doing it , there might be something wrong with the radio.
Can you have it showing your -100 and move the slider to see if it changes the value , just a thought.

hkfanatic
31st August 2014, 08:07 AM
I did, hp. I created a new model, I used a new receiver, I used a new cable, I assigned channel 5 to different sliders/knobs on the transmitter, etc. They all worked just fine until I assign PPM5. Then it puts out a -100.

I then compared each and every setting with my son's X9D and found nothing different which leads me to believe my transmitter has a defect.

Thanks so much for your time, hp.

hpcoolahan
31st August 2014, 08:11 AM
bummer man , at least you narrowed it down .
Hope it gets sorted for you , how old is the tx?

hkfanatic
31st August 2014, 08:27 AM
Honestly, I just started on this hobby this year. I think I bought the transmitters sometime February/March and flew my maiden flight in April. I'm going to write FrSky in a while and tell them about my predicament. I'm also going to get in touch with the shop where I bought it from, hopefully they'll do something about it.

Yup, on the brighter side, my headtracking works flawlessly. The movement is so smooth, reaction is lightning-quick, and I didn't notice any hiccups/skips. The quality of the video however isn't that impressive at the moment. I still need to test whether it's the camera, the vtx, or the goggles itself. But based on the reviews of the other early owners, I doubt if it's the goggles itself. Any tips/reminders?

I'll keep you posted on this. Or maybe I can post a photo of the video quality.

hpcoolahan
1st September 2014, 01:20 AM
Shoot up a pic of the set-up on your plane /multi-rotor , that might help in figuring out the video interference.
Video will also help if you can. ;)

hkfanatic
3rd September 2014, 06:24 AM
Hi, HP.

I was able to fix the PPM5 issue with one of my transmitters. Apparently, it was caused by a Jurassic version of the firmware. When the transmitter reformatted the eePROM (after I tried to save my models to the Txr), the PPM5 wasn't stuck at -100 anymore.

'Hope this helps, in case any of your other customers would experience the same problem.

Next stop: video quality

Cheers, mate!

hpcoolahan
4th September 2014, 03:35 AM
Wow , didn't see that one coming .
So a firmware update had to be done on the radio , look at it this way , It now works ;) well done !!