PDA

View Full Version : TBS EZOSD



radicalron
31st March 2014, 10:57 PM
Whats up TBS , Trappy . I bought a TBS EZOSD approx 1 1/2 to 2 years ago. Could you email me the firmware for it. I tried to put immersion firmware and it don't work. My email is radicalron@roadrunner.com . The current sensor took a shit and I tried to recalibrate it and I thought Ihad TBS firmware but it was immersions. What a pain in the ass. lol Thanks Trappy (TBS) Ron

radicalron
1st April 2014, 11:09 AM
How long is the normal time for a response??

kpaine
1st April 2014, 02:03 PM
I submitted a support ticket and received the firmware that evening. I would try that.

http://team-blacksheep.freshdesk.com/support/home

radicalron
2nd April 2014, 11:20 PM
Okay ,Thanks I'll give that a shot.. Ron

EHLO
3rd April 2014, 03:35 AM
Hi All, does anybody know what is the latest recommended firmware for the TBS EzOSD ?

radicalron
5th April 2014, 03:29 PM
Thanks TBS for the fast response!! I reloaded the firmware and all is good. Thanks Ron

tesc0
10th May 2014, 12:19 PM
Can I also have a copy of the latest firmware? hoping a reflash will bring the text back. I am getting telemetry to my iphone but nothing on screen :/

tesc0
10th May 2014, 12:57 PM
Unless anyone else has any ideas? its getting the correct GPS fix too as thats showing up on the app.