Results 1 to 4 of 4

Thread: crossfire with new t16sz issue

  1. #1
    Navigator
    Join Date
    Jan 2012
    Location
    Erie
    Posts
    760

    crossfire with new t16sz issue

    Hope somebody has come across this.
    I just picked up a new Futaba t16sz and can not get it to work with my crossfire.
    I've tried looking up the problem with other sz tx's. Tried everything I can think of, teacher, student, 12, 8, and 16 channel. All output settings, individual battery.
    Teacher mode will turn on the crossfire thru the trainer cable, but ppm output is across a different pin # then, ( #5 vs. #1 ).
    Supposedly, student mode and an independent battery was supposed to work, but I can find no reference anybody has been successfull. For me, all I get is everything going wonky.
    Any ideas? Looking for a chicken to sacrifice now!

  2. #2
    Navigator
    Join Date
    Jan 2012
    Location
    Erie
    Posts
    760
    Problem solved.

    Not sure what I was doing wrong. The set-up is pretty simple. Trainer selected, activate, set to student, set to 12 channel, set switch to ... , ( always on ).

    Did a new set-up on my micro-wraith, using the micro-receiver, operates just fine. Sure wish I knew what the hell I was doing wrong? Sometimes it's the simple stuff.

  3. #3
    Pilot doobie's Avatar
    Join Date
    Jan 2015
    Location
    ontario canada
    Posts
    1,473
    maybe someone sacrificed the chicken when u wernt looking???
    flyin HIGH

  4. #4
    Navigator
    Join Date
    Jan 2012
    Location
    Erie
    Posts
    760
    Best I was going to be able to do was a rabbit.

    Happy as can be now,, just love this new radio!

Similar Threads

  1. Taranis XD9+ Crossfire CRSF issue
    By Tfmace in forum TBS Support
    Replies: 0
    Last Post: 24th November 2017, 06:46 PM
  2. CrossFire micro rx v2 wiring issue in Vendetta v2
    By Haya in forum Team-Black Sheep
    Replies: 1
    Last Post: 16th November 2017, 07:21 PM
  3. Throttle issue with Crossfire
    By WNCFPV in forum Team-Black Sheep
    Replies: 7
    Last Post: 15th November 2016, 02:57 PM
  4. Throttle issue with Crossfire
    By WNCFPV in forum TBS Support
    Replies: 0
    Last Post: 9th November 2016, 11:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •