Results 1 to 6 of 6

Thread: issue with binding x4r-sb to frsky x9d and tbs vendetta

  1. #1

    issue with binding x4r-sb to frsky x9d and tbs vendetta

    hi guys really new to racing quads first off.

    so I've tried for 3 nights in a row to get my new tbs vendetta up and running.

    i think my issue is more that i can't bind it to my frsky x9d V1 not plus model tx.

    i have a frsky x4rsb receiver which i bought new.

    I've updated the firmware on my x9d to v open tx 2.1.9 successfully
    I've updated my firmware on the receiver to the eu version

    binding process I've used is to turn on tx
    go to bind, wait for it to start beeping
    hold down f/s button on rx
    apply power

    at this point all i get is loud beeping from the tbs
    once i exit out of bind mode and reboot all i get is a red flashing light on the rx?

    I'm wishing i just didn't waste my money as here in the uk there is most likely no-one who can help hands on, I've been pretty patient and tried my best to follow guides videos on youtube.

    like i said i know for sure I've installed the firmware on the tx, well i know its version 2.1.9 now and the boot loader is 2.1.9
    the rx i flashed and pretty sure i done it successfully.

    pretty frustrated with it all and hoping theres someone here who knows where if i have gone wrong or doing something stupid?

    also its on d16 mode. i could make a video of whats happening if this would help.

    thanks a lot for taking the time to read this post and any help would be much appreciated


  2. #2
    Anyone ???

    Binding x4r to frsky taranis? Surely somone knows where I'm going wrong?

  3. #3
    Join Date
    Jul 2013
    Lincolnshire UK
    Did you upgrade the internal XJT module in the taranis to the eu firmware?

  4. #4
    I upgraded the opentx from 2.0.1 or somthing like that to 2.1.9 I was under the understanding that's updating for the internal tx?

  5. #5
    Join Date
    Jul 2013
    Lincolnshire UK
    That updates the Taranis firmware not the internal XJT radio firmware.

  6. #6
    Hi guys, so I managed to use my mac to easily do the firmware on the internal xjt simple drag drop. Now the rx will go solid green. Onto the next step with calibrating the tbs, hopefully that will be abit easier on me ��

Similar Threads

  1. Replies: 2
    Last Post: 30th November 2017, 09:08 PM
  2. Frsky XSR not binding with taranis x9d+
    By Stres in forum RC TECH
    Replies: 0
    Last Post: 18th November 2016, 11:16 AM
  3. New Vendetta, Tango, Crossfire TX and RX Micro V2 Binding Issue
    By nurofenplus in forum Team-Black Sheep
    Replies: 7
    Last Post: 9th October 2016, 03:40 AM
  4. Binding Frsky D4RII Failsafe issue
    By TWT in forum ROTORCRAFT
    Replies: 3
    Last Post: 28th June 2015, 06:29 AM
  5. EZUHF Binding Issue. Help Please!
    By eddie200112 in forum ImmersionRC
    Replies: 10
    Last Post: 6th August 2013, 12:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts