Results 1 to 1 of 1

Thread: Can't get passed "Waiting for PPM", can't enter OSD menu

  1. #1
    Join Date
    May 2016

    Can't get passed "Waiting for PPM", can't enter OSD menu

    Hi all,

    [SOLVED]: BST cable from Rx to FPVision stack is not sufficient, one needs to connect the Rx channel(s) as well.

    I have a Powercube 2in1 FPVision with a Crossfire Micro receiver and GPS/Compass connected to it (via BST splitter). Running the standard Crossfire Module on the Tx. I have updated the CRSF Tx, Rx and GPS/Compass via TBS agent (using a PNP Pro for the Micro Receiver) to the latest stable version. I did not reflash the Colibri. Binding the Micro RX worked like a charm, green solid LED on both Tx and Rx.

    After powering up the Powercube it runs through the selftest, detects the GPS and then says RC calibration needed. I only get "Waiting for PPM", with centered sticks on the Taranis running OpenTX 2.2.0 final with channel order TAER. On the CRSF Tx, when I enter the menu, and go to "Micro RX", Output 1 is set to PPM. If I override the RC calibration, I see the OSD but cannot enter the OSD menu with throttle 0 and yaw left.

    Switching through the different protocols with the button on the OSD does not bring up anything useful but shortly but horribly violently spins up the connected endurance motors almost every time the protocol is switched. You might want to consider fixing that.

    Any clue what I am doing wrong? Thanks!
    Last edited by dmy; 10th September 2017 at 08:19 PM.

Similar Threads

  1. Replies: 2
    Last Post: 23rd December 2015, 03:00 PM
  2. Replies: 68
    Last Post: 10th February 2015, 02:24 PM
  3. Replies: 3
    Last Post: 27th January 2014, 04:34 PM
  4. Replies: 7
    Last Post: 14th July 2013, 04:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts