Results 1 to 6 of 6

Thread: How to set up gimbal / servo on TBS powercube calibre

  1. #1

    How to set up gimbal / servo on TBS powercube calibre

    Ok still cant figure it out. On basic f3 boards the servo(s) connects to motor pins 1,2 (or updated versions motor pins 5, 6). But the powercube has a dedicated servo port.


    Ive been in the cli tabs and resource shows the motor pins are C06 to B15. If tried all the free pins (A00,A01 etc) but cant find the dedicated servo pin port. The led strip is on A06, so I tried all around it (A05, A07 etc). But no luck

    Any ideas

    I have considered forgetting the servo port and just solder a wire to motor 5 pin (A00). But doing this I still dont know which PHYSICAL PIN is the motor 5 pin (calibre uses motors pins connected directly to the esc bourd once stacked.

  2. #2
    101 views and not a single clue? C'mon, I thought the TBS brainiacs haunted these boards.
    My mind is outta gas, I need someone to throw me a bone.

    I was thinking that if I went to the cli tab and typed the command "resource list" it would list all the "resources " (peripherals etc) attached to the board and then pin address they are attached at. But the list doesnt mention anything about servo although I have the servo physically plugged in and the board powered up.
    Last edited by noir522; 26th July 2017 at 01:11 PM.

  3. #3
    MrTakeNoPrisoners PeteDee's Avatar
    Join Date
    Apr 2013
    Canberra, Australia
    What is a "calibre"?
    similis vobis fugere eam furatus!

    • Edith Sitwell "I am patient with stupidity but not with those who are proud of it."

  4. #4
    Quote Originally Posted by PeteDee View Post
    What is a "calibre"?
    What you've never seem GAME OF THRONES??

  5. #5
    Just joking that would be Kaleesi.

    the calibre is the the name of the actual flight controller board of the TBS powercube

  6. #6
    Ok solved.
    For the pitch servo (all I needed) the dedicated servo pins on the side of the colibri is B14 (motor 9 pin)

    1)connect servo to the side"servo" pin

    2)In the configuration tab enable servo tilt

    in cli tab
    3)"resource motor 9 none"
    4) "resource servo 1 B14"

    Hope my frustration/solution helps someone

Similar Threads

  1. help with powercube and x4r
    By Gorillionaire in forum RC TECH
    Replies: 1
    Last Post: 25th March 2016, 11:53 AM
  2. Replies: 0
    Last Post: 28th February 2015, 10:19 AM
  3. Replies: 0
    Last Post: 25th August 2014, 11:32 AM
  4. Replies: 6
    Last Post: 27th April 2014, 07:20 AM
  5. Cheap servo powered camera gimbal
    By airwolf in forum ROTORCRAFT
    Replies: 5
    Last Post: 3rd July 2013, 10:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts