image
Results 1 to 5 of 5

Thread: Pixhawk connection problem

  1. #1

    Pixhawk connection problem

    I have a new Pixhawk and it won't connect to Mission Planner. I got the firmware in it and my computer see's it on com106 in the device manager under comports. It still won't connect. Deleted MP and reloaded it. Hit the reset button. held button while powering to enter bootloader mode. Firmware is installed but won't connect with MP.

  2. #2
    Navigator Beerwiser's Avatar
    Join Date
    Oct 2011
    Location
    Locked in then trunk of a car.
    Posts
    663
    Try uploading a copter or plane, whichever you don't want. Also try a different cable and usb port. I had that happen on one pixhawk.
    "You get what you put in, and people get what they deserve"
    Kid Rock

  3. #3
    Co-Pilot Pushjerk's Avatar
    Join Date
    Dec 2012
    Location
    PNW
    Posts
    1,567
    I had trouble updating FW with a new unit recently. Was trying to load updated Y6 firmware. It finally connected when I tried to load arduplane FW, then after that just swapped the FW to copter. It's a finicky little bitch sometimes.

    On another unit, had to use APM Planner on a Mac to load new firmware, then hook it up to my PC and Mission Planner (my preference) to start configuring.

    Sometimes disconnecting most peripherals will will help you connect. Sometimes using the reset button instead of unplugging/plugging when installing FW is key.

    Lots of good tips on DIYDrones as well. Just google DIYDrones Pixhawk and some key words suited to your issue.
    "That aircraft is nothing but a bunch of spare parts flying in close formation!"

  4. #4
    Co-Pilot Pushjerk's Avatar
    Join Date
    Dec 2012
    Location
    PNW
    Posts
    1,567
    Another tip, you can actually get 3DR tech support in live chat to work with you real time for any issues.
    "That aircraft is nothing but a bunch of spare parts flying in close formation!"

  5. #5
    Thanks guys. Figured out the sd card wasn't properly inserted. Fixed that and it worked. Thanks again.

Similar Threads

  1. Immersion Rc Tramp and Pixhawk Serial connection
    By Mark97564 in forum ImmersionRC Support
    Replies: 2
    Last Post: 21st March 2017, 10:58 AM
  2. Xu Gong V2 pro Connection Problem
    By Lumix in forum ImmersionRC Support
    Replies: 10
    Last Post: 13th April 2016, 02:53 PM
  3. Teleporter V3 and FPV Freerider. Connection problem.
    By imagy in forum Fatshark Support
    Replies: 0
    Last Post: 6th April 2016, 08:40 PM
  4. Hubsan x4 FPV connection problem with skyzone.
    By Liiban88 in forum ROTORCRAFT
    Replies: 0
    Last Post: 23rd July 2015, 04:37 PM
  5. Help Diagnosing my Problem -- ImmersionRC 5.8 vTx Antenna Connection
    By kslee106 in forum IFR - Video Link Discussion
    Replies: 2
    Last Post: 8th November 2013, 06:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •