Page 2 of 7 FirstFirst 1234 ... LastLast
Results 11 to 20 of 61

Thread: Poor Range with Crossfire?

  1. #11
    I will do some more tests today and get back to you guys. I will also be doing some comparative tests with another crossfire tx and rx that my buddy has. I am experiencing the same range with both Rx's. And yes by signal lost I mean failsafe kicked in and the radio lost all connections to the quad.

  2. #12
    I saw someone mention the antennas on the rx. That will make a huge difference. Silver should be vertical and black should be horizontal 90 degrees from each other....



    Sent from my iPhone using Tapatalk

  3. #13
    Quote Originally Posted by Reaper_19 View Post
    I saw someone mention the antennas on the rx. That will make a huge difference. Silver should be vertical and black should be horizontal 90 degrees from each other....



    Sent from my iPhone using Tapatalk

    I have tested all types of antenna orientation including similar to your picture. Thanks for your help but the micro Rx does not have diversity antenna's, diversity antennas should be 90 degrees from each other but this micro rx has a dipole and should be linear in shape. The antenna should be in a straight line from one end to the other to work as a dipole.

  4. #14
    Quote Originally Posted by Reaper_19 View Post
    I saw someone mention the antennas on the rx. That will make a huge difference. Silver should be vertical and black should be horizontal 90 degrees from each other....



    Sent from my iPhone using Tapatalk
    This is not the best way to mount the micro receiver antenna.

    I've had the same issues no matter how I mounted it.

    Had a failsafe at 59m at 500mw albeit thru a car or two but still, the fact my FrSky receivers are beating my Crossfire means there is definitely something wrong.

    I don't think it's software. At this point I'm beginning to believe a batch of bad v2 receivers shipped somehow.

    I have time today to walk test my 3 v2 receivers, one I just pulled from it's package.

    I can 100% say I'm not getting the advertised range and at 500mw I can't imagine noise floor being the issue.

  5. #15
    Quote Originally Posted by LCurole View Post
    This is not the best way to mount the micro receiver antenna.

    I've had the same issues no matter how I mounted it.

    Had a failsafe at 59m at 500mw albeit thru a car or two but still, the fact my FrSky receivers are beating my Crossfire means there is definitely something wrong.

    I don't think it's software. At this point I'm beginning to believe a batch of bad v2 receivers shipped somehow.

    I have time today to walk test my 3 v2 receivers, one I just pulled from it's package.

    I can 100% say I'm not getting the advertised range and at 500mw I can't imagine noise floor being the issue.
    Keep us updated on your tests. I'll post up later how my day went.

  6. #16
    I see now, thought you had the diversity micro rx's. Have you tried changing the frequency via the crossfire settings menu and and also update everything via TBS Agent on your computer?


    Sent from my iPhone using Tapatalk

  7. #17
    Quote Originally Posted by Reaper_19 View Post
    I see now, thought you had the diversity micro rx's. Have you tried changing the frequency via the crossfire settings menu and and also update everything via TBS Agent on your computer?


    Sent from my iPhone using Tapatalk
    There is no such thing as a diversify micro and all micros have the same antenna.

    I've been on 915mhz the whole time as well as the latest Crossfire beta firmware.

  8. #18
    Sorry not diversity but the antenna that came with mine has 2 leads coming out of it...



    Sent from my iPhone using Tapatalk

  9. #19
    I'm thinking about a bad rx for mine too... My X4R beats the micro, and I have no issue with the big diversity. I'll do some more testing this week-end and then i'll be done with it, definitively.

  10. #20
    Quote Originally Posted by Reaper_19 View Post
    Sorry not diversity but the antenna that came with mine has 2 leads coming out of it...



    Sent from my iPhone using Tapatalk
    Yeah, thats the dipole for the Micro Rx, it is supposed to be in a straight line, (linear).

Similar Threads

  1. 1.2G video poor range
    By giteart in forum IFR - Video Link Discussion
    Replies: 29
    Last Post: 21st May 2015, 01:07 AM
  2. LRS poor range/200 yards
    By ThisIs84 in forum RC TECH
    Replies: 22
    Last Post: 27th January 2015, 06:28 AM
  3. New FPV setup - very poor range
    By Rant6 in forum IFR - Video Link Discussion
    Replies: 5
    Last Post: 24th November 2014, 05:36 PM
  4. Poor range with FS Attitude
    By rnelias in forum Fat Shark R/C Vision Systems
    Replies: 3
    Last Post: 15th July 2013, 09:54 PM
  5. Poor video range...
    By Ez Hawk in forum IFR - Video Link Discussion
    Replies: 22
    Last Post: 8th May 2012, 03:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •