Page 5 of 5 FirstFirst ... 345
Results 41 to 46 of 46

Thread: Poor Range with Crossfire?

  1. #41
    Navigator
    Join Date
    Aug 2015
    Location
    Belgium
    Posts
    60
    So I think (and I hope) I managed to figure out the issues with my system. Here's an annotated side view of my quad:



    In green is the antenna wire going up my PTFE tube, blue is the ground part coming back down. Now the end of the ground part always used to be bent like the yellow bit indicates (plus a bit inwards the quad, hard to show in 2D). This always resulted in my Taranis complaining about low or critical RSSI (with the standard thresholds) like there's no tomorrow. Even today. Then eventually for some unrelated reason, I bent it like the purple part indicates, my RSSI when I'm about to take off went from ~65 to ~73 on the OSD scale (whatever moon units that represents, but it seems significant), the Taranis stopped complaining about RSSI, and I didn't notice any more random short bouts of control loss.

    My suspicion is that it picked up RF crap from the camera, that interfered with the receiver. The electrics themselves are relatively clean, because there's capacitance and filtering all over the place (altho I still want an oscilloscope eventually to tune this). And it used to happened randomly at hover, not just at load changes that cause lots of EMI.

    Knocking on wood that this drama is over.


    (Also, why the hell is this site still so slow after days?)

  2. #42
    Navigator
    Join Date
    Jul 2014
    Location
    Allen TX USA
    Posts
    167
    Quote Originally Posted by Glowtape View Post
    Knocking on wood that this drama is over......
    FWIW - I have two new builds using the micro and I shoved both the black and the silver antenna parts up the drinking straw - has been working perfectly so far. One of the builds even has the VTX antenna 25mm away.

    http://fpvlab.com/forums/showthread....l=1#post832048

  3. #43
    Navigator
    Join Date
    Aug 2015
    Location
    Belgium
    Posts
    60
    I suppose it might work on close range, but I think folding up the ground plane part next to the active part is discouraged, because the ground part essentially receives the complementary version of the signal of the active part and things may cancel out. The reason this still works at all are probably differences in gain on both parts.

  4. #44
    Navigator
    Join Date
    Jul 2014
    Location
    Allen TX USA
    Posts
    167
    Thats the ambiguous part, I do not believe the black wire is meant to be a ground plane. I *think* it is more of a balun that acts to stop the RF from feeding back into the transmitter. As soon as these cyclonic winds here in North Texas die down to something reasonable I'll do a long distance run and see what happens.

    If the inventor of that antenna would chime in here that would be great. Numerous moon units would be awarded.

  5. #45
    Quote Originally Posted by Glowtape View Post
    So I think (and I hope) I managed to figure out the issues with my system.
    I'm glad you found something. Keep us informed.

    While testing I hit a failsafe, broke the antenna near the connector, can't replace the antenna without fine soldering, in a angry I trash it and bought the big diversity receiver... I'm done with the micro, it works fine for some and works poorer than a cheap frsky for other, nobody knowns really what to do, the range is aleatory and I hate aleatory issues.

  6. #46
    Navigator
    Join Date
    Aug 2015
    Location
    Belgium
    Posts
    60
    Yeah, the jump in RSSI was surprising, and that happened before the motors were spinning, so the camera was really the only culprit here at this point.

Similar Threads

  1. 1.2G video poor range
    By giteart in forum IFR - Video Link Discussion
    Replies: 29
    Last Post: 21st May 2015, 12:07 AM
  2. LRS poor range/200 yards
    By ThisIs84 in forum RC TECH
    Replies: 22
    Last Post: 27th January 2015, 05:28 AM
  3. New FPV setup - very poor range
    By Rant6 in forum IFR - Video Link Discussion
    Replies: 5
    Last Post: 24th November 2014, 04:36 PM
  4. Poor range with FS Attitude
    By rnelias in forum Fat Shark R/C Vision Systems
    Replies: 3
    Last Post: 15th July 2013, 08:54 PM
  5. Poor video range...
    By Ez Hawk in forum IFR - Video Link Discussion
    Replies: 22
    Last Post: 8th May 2012, 02:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •