I recently got an Elite bundle that will be going into a Shendrones Kreiger with Tiger Motors F60s and Tiger motors F30 ESCs.
The problem I'm having is that the Colibri Race V2 that comes in the bundle will not communicate with either of my PCs. I've tried going through TBS support but they apparently are located on the other side of the globe and it's very difficult to get support when a maximum of one email exchange occurs per day due to the time difference. This is the information I've provided them.
Hi, I recently purchased an Elite Bundle and I'm having trouble getting it connect to my PC(s). My Win 10 desktop doesn't do anything and my Win 8 laptop will see it but not recognize it and when I got to device manager it will not allow me to update the driver.
I've tried the TBS Agent, DfuSe Demo (DFU Updater STM32080) and as mentioned above I tried to update its driver with VCP V1.4 (STM32102), nothing works.
I am able to interact normally with my Motolabs Cyclone and my Lumineer LUX flight controllers but I can't seem to get the computers to see the Colibri.
Is there a problem with the Colibri or is there something I haven't tried?



[COLOR=rgba(255, 255, 255, 0.8)]K[/COLOR]

FYI: The FPVision layer connects immediately and is configurable in the TBS Agent.



[COLOR=rgba(255, 255, 255, 0.8)]K[/COLOR]

When I attempt to enter stick calibration on the FPVision it says no RC supplier or FC found. (Using known good SBUS receiver)



[COLOR=rgba(255, 255, 255, 0.8)]K[/COLOR]

With USB plugged in the only LED that is lit is LED2 (Near boot switch) - solid blue
With battery plugged in (USB unplugged) the same LED2 is solid blue and 5V LED (Near stack pin header) is solid blue. No other LEDs light up on FC.



[COLOR=rgba(255, 255, 255, 0.8)]K[/COLOR]

Disconnected everything from Colibri and removed it from the FPVision and attempted to connect with Win 10 and Win 8 computers again with nothing connected to the FC. Same result, no connectivity and just LED2 solid blue, no other LEDs flash or remain lit.



[COLOR=rgba(255, 255, 255, 0.8)]K[/COLOR]

Reinstalled Colibri on FPVision and left everything disconnected except the XT60 battery connector.


VDC at +5.1V Stack header pin while connected to Tattu 4s 1300mAh (USB disconnected) : 5.21V
VDC at +12.2V Stack header pin while connected to Tattu 4s 1300mAh (USB disconnected) : 5.21V


VDC at +5.1V Stack header pin while connected to USB (4s Batt. disconnected) : .222V

VDC at +12.2V Stack header pin while connected to USB (4s Batt. disconnected) : .222V


Voltage across standoffs with battery connected is battery voltage.
No voltage dropped across standoffs while connected to USB only.


Not sure if any of this helps...



[COLOR=rgba(255, 255, 255, 0.8)]S[/COLOR]


Hi,



See attached file and measure the encircles pins if you'e getting something. If not, go down to FPVision and check the same pins on it there's something.


If FC is getting voltage, send here a short video describing the issue and I will show it to our engineer to get more info.


Best regards,






Customer Service Representative
TBS Avionics Co Ltd.

www.team-blacksheep.com
helpdesk.tbs@gmail.com

-----
Ticket online: http://team-blacksheep.freshdesk.com/helpdesk/tickets/




JPG
Colibri - FC...
(73.1 KB)




[COLOR=rgba(255, 255, 255, 0.8)]K[/COLOR]

I've already given you the voltage for those pins on the colibri and the voltage at the same pins on the FPVision layer are the same, 5.2 volts on both pins while connected to 4s battery.


[COLOR=rgba(255, 255, 255, 0.8)]S[/COLOR]




Referred your case to our engineer and he's suspecting problem is signal from the FPVision is not going through the FC which giving the No RC supplied or FC not found error. Signal can't be measured with multimeter but with special equipment like oscilloscope. Difficult to debug without checking the physical cube.


He' suspecting that problem may lie on the external ESC board, the header specially. Do you have spare? Or would you be willing to send the cube back to our office to further check?


Best regards,




Customer Service Representative
TBS Avionics Co Ltd.

www.team-blacksheep.com
helpdesk.tbs@gmail.com

-----
Ticket online: http://team-blacksheep.freshdesk.com/helpdesk/tickets/





[COLOR=rgba(255, 255, 255, 0.8)]K[/COLOR]

I doubt the problem lies in the external ESC board as I chose not to use it. I removed it from the assembly before installing it in the frame.I'm also not sure that the FPVision layer is responsible for the malfunction because I completely removed the FC from the stack and attempted to get it to communicate on its own and it did nothing. Unless the FPVision layer permanently damaged the FC.


I'd like to ship this back to you for testing but I need some more information first.
Like where to ship it?
Who is paying for shipping?
How long will this take?
Will you be sending me a functioning unit first?



That's where I'm at after a few days of beating my head against the wall. If anyone has come across this before or has any additional information I would be thankful. If anyone has a properly functioning bundle and could tell me how their LEDs on both the FPVision and the Colibri act while initially connecting the battery or while connected and idle or while in DFU I would appreciate it. Or if you could tell me the voltages you have at the 5 and 12V pins in the stack header that would help too. To be honest I'm no electrical engineer but at this point I'm fairly certain one or both pieces are defective but I'm trying to give the bundle the benefit of the doubt. As this is my first TBS FC I'm not entirely certain how it should behave when only the Colibri is connected to the PC via USB so if anyone has experience with connecting, updating and configuring the FC alone please share your experiences. Thanks again.