image
Results 1 to 7 of 7

Thread: Problems with latest iOSD mini firmware upgrade

  1. #1

    Problems with latest iOSD mini firmware upgrade

    Hello All,

    I recently tried to use my Naza Assistant 4.1 software to check the parameters and firmware version on my DJI iOSD Mini, and noted that it told me that I needed to upgrade the firmware before I could continue to the Main screen. The odd thing was that it showed that my current firmware was 4.00, and the firmware upgrade was to V 4.0. OK - well, I had just seen a similar thing with the NAZAM Assistant, so I wasn't too puzzled by this. However, it became more interesting when the splash screen stated that the new firmware was V 3.03 - not 4.00. But I went ahead and updated. Everything went fine, the firmware upgrade completed successfully,and I was able to go to the main screen. But then I noticed that my changes were not being written and saved. So I power-cycled and went back into the Assistant.

    When it started again, it gave me the same firmware message! It stated that the firmware was "mismatched" (though the current and upgrade numbers were still 4.00 and 4.0 respectively), but I had to upgrade again just to be able to access the main screen. And yet again, the values I entered would not write.

    My GUESS is that the Assistant loaded the iOSD Mark II firmware into my iOSD mini, rather than the V 3.03 firmware - which I suspect is the correct firmware for the iOSD mini. Luckily, the iOSD continues to function, though I can't set the parameter values or the display boarders as I'd like.

    Has anyone else experienced this? I've sent DJI support an email, and will report back if I get an answer. (I've also noticed that it has become much harder to find the support page (downloads, etc.) for the NAZA system components. It appears to me that DJI may be moving away from the individual components and focusing on complete multirotor airframes - but that's conjecture on my part and a subject for another thread.)

    Melsman

  2. #2

    UPDATE - Watch the firmware version!

    DJI tech support responded quickly, and I had to send them a video of what was happening. But, they did help me down-grade my iOSD mini firmware. (It's not a very obvious procedure.)

    For some reason, the iOSD Assistant 4.1 thinks that my iOSD mini's (I have two of them) should be upgraded to Firmware Version 4.00. Well, they shouldn't. The most recent iOSD mini firmware is V 1.04. So, if you happen to connect your iOSD mini to the iOSD Assistant, and it tries to tell you to upgrade to Firmware 4.0 - Don't do it! Otherwise, you'll have to contact tech support so they can walk you through the downgrade steps.

  3. #3
    Hi Melsman, just picked up my iosd mini and did exactly the same as you......
    Are you able to describe the steps you went through to roll the firmware back?
    Its working fine, it would just be nice to write to it to suit my FPV display.

    Thanks in advance!

  4. #4
    Hey Crossbones - I replied to your PM on this subject. But your question is similar to others I've received since posting this. So, for any who have this same issue, here's what I recommend:

    The downgrade process was done via email. Try sending an support email to them through their www.dji.com/support site. They responded very fast to me. I worked with a guy named Amos and another named Ian. Both were very helpful. Title your request "4.1 Assistant appears to be loading wrong firmware for iOSD mini". (By using a consistent title in the support request, they can gauge the impact of this issue and give hard data to the software engineers in order to affect a change.) Send me a PM to let me know how it goes.

  5. #5
    Me, too, did exactly the same - before I found this thread. Just tick me off that I got into this problem just because I followed the directions. Called them on the phone, after a bit of investigating, they want me to send it back for repair, which I don't want to do. I tested it (hook it up to the monitor) and I see it working fine so I just ignore the firmware version issue (and just never connect it to a computer)

    Please post if you have the direction/steps to downgrade the firmware.

  6. #6
    Hi Haiquocpham - I've heard others say that when they called, the person on the phone told them that it could not be fixed - which is not what the folks on the email support side said. That's why I'm encouraging everyone to email support. Obviously, they have an issue that they're not addressing consistently in their tech support department; not to mention that they have a bug on the firmware update routine of their iOSD Assistant 4.1 that needs to be corrected ASAP. Having worked in a similar tech industry, I know how these things work internally. They need to collect data to convince skeptical managers that a problem exists and needs to be addressed.

    Now - for those who have already contacted tech support via email... were all of you able to get the problem fixed?

  7. #7
    I can't guarantee this will work for everyone, but I had the same problem. Had just finished fixing a P2 purchased O.L. from another party, and he had made some erroneous wiring to iOSD mini. I bought a ready made harness and everything worked until I went into upgrading iOSD firmware. My iOSD is installed inside the Phantom, therefore the GPS was ALWAYS disconnected when running the DJI Assistant. Time after time I saw the message: Firmware mismatch and I couldn't get back to the mainscreen to move data on Left side.

    I remembered having trouble with another brand that required EVERYTHING be plugged in to launch firmware, so I plugged in the GPS and everything obeyed my commands. Got the main page and wrote in the new location - no problem.

    So if anyone else has this problem - make sure GPS is plugged in - and let us know if it was as simple as my experience.

Similar Threads

  1. Replies: 10
    Last Post: 28th July 2016, 05:26 AM
  2. Replies: 11
    Last Post: 25th February 2016, 02:58 PM
  3. Tiny Telemetry Latest Firmware
    By CAMOMAN in forum ImmersionRC
    Replies: 5
    Last Post: 9th August 2015, 08:02 AM
  4. TBS EzOSD Latest Firmware
    By tenright in forum Team-Black Sheep
    Replies: 12
    Last Post: 9th November 2013, 06:14 PM
  5. problems with EZOSD setup and firmware upgrade
    By jetbootz in forum ImmersionRC
    Replies: 85
    Last Post: 5th May 2013, 05:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •