Page 13 of 13 FirstFirst ... 3111213
Results 121 to 126 of 126

Thread: Powercube FPVision

  1. #121
    Navigator
    Join Date
    Feb 2013
    Location
    Westerville, OH
    Posts
    156
    I'm also trying to figure out what the best camera would be to pair with the FPVision cube. I would love audio so that would make me lean towards the zero zero V2 but I just don't like the quality of the picture knowing there is much better out there.

  2. #122
    Navigator
    Join Date
    Mar 2017
    Location
    Redneck Rivera, Florida
    Posts
    2
    Hey guys I picked up the new Atom V3 last month and I'm having some problems with the OSD flickering and disappearing. Thought maybe I had a fried vtx so I ordered a new PowerCube Vision and installed it today. I carefully checked all connections before powering up and to my extreme disappointment it is still flickering/disappearing. Any ideas on what may be going on?

  3. #123
    Quote Originally Posted by FlyDriver View Post
    Hey guys I picked up the new Atom V3 last month and I'm having some problems with the OSD flickering and disappearing. Thought maybe I had a fried vtx so I ordered a new PowerCube Vision and installed it today. I carefully checked all connections before powering up and to my extreme disappointment it is still flickering/disappearing. Any ideas on what may be going on?
    Sounds like my issue. I got my OSD stable with the Camera of my Vortex250. But since this camera is crap I much rather fly with my RunCam Swift2 and can read the OSD only sometimes
    I also tested my FPVision with the Camera of my Atom V2. I has the same flicker like the Swift, Swift2 and the Foxeer HS1177..

    I'm hoping on a Software-side fix for this issue.. I also have opend a ticked with TBS and were looking into the problem
    Last edited by RBNFPV; 20th March 2017 at 05:59 AM.

  4. #124
    Navigator
    Join Date
    Mar 2017
    Location
    Redneck Rivera, Florida
    Posts
    2
    Quote Originally Posted by RBNFPV View Post
    Sounds like my issue. I got my OSD stable with the Camera of my Vortex250. But since this camera is crap I much rather fly with my RunCam Swift2 and can read the OSD only sometimes
    I also tested my FPVision with the Camera of my Atom V2. I has the same flicker like the Swift, Swift2 and the Foxeer HS1177..

    I'm hoping on a Software-side fix for this issue.. I also have opend a ticked with TBS and were looking into the problem
    Yes that's exactly what mine is doing! When I initially power up it will stay on for about 30 seconds and then commence to flickering, ultimately disappearing.

  5. #125
    I no longer see any video from my TBS Vision board. I haven't even flown the quad yet. Was working the other day, now there is nothing - no black screen even. Performs this way whether my working camera is plugged into port 2 or not connected.
    I've reflashed the latest version to no avail.
    Anything I can do to troubleshoot?

  6. #126
    Here's the solution:
    Buy a new board, and replace broken one.
    I also had problems entering the osd menu with this old board.
    New one work flawlessly.

Similar Threads

  1. TBS POWERCUBE
    By Sandman1646 in forum Team-Black Sheep
    Replies: 1621
    Last Post: 27th March 2017, 05:47 AM
  2. LEDs for TBS PowerCube
    By SeanyP in forum Team-Black Sheep
    Replies: 3
    Last Post: 17th March 2017, 04:27 PM
  3. PowerCube and DFU Not Getting Along
    By WingsThree in forum TBS Support
    Replies: 0
    Last Post: 4th May 2016, 05:03 PM
  4. Need help with my TBS powercube!
    By Smallz in forum OSDs & Flight Controllers
    Replies: 0
    Last Post: 4th May 2016, 12:37 PM
  5. help with powercube and x4r
    By Gorillionaire in forum RC TECH
    Replies: 1
    Last Post: 25th March 2016, 11:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •