Results 1 to 10 of 10

Thread: Vendetta XT60 connector broken. How to remove ?

  1. #1

    Vendetta XT60 connector broken. How to remove ?

    Hi everyone,

    Just got my vendetta last Tuesday; I've been out today and have had a very minor crash in an open field; the craft landed upside down though and this has actually broken the XT60 connector on the Vendetta so that the batteries are loose when plugged in.

    Are there any instructions on how to remove the XT60 connector from the vendetta? I have undone the screw that holds the "XT60 Lock" in place, but the plastic lock itself won't budge. Is there some trick to this?

    Regards
    MadmanK

    EDIT : I have managed to release the lock; needed to loosen the 'cube' a little then it lifted straight out with a little convincing :-)
    Last edited by MadmanK; 31st May 2016 at 06:10 AM.

  2. #2
    As a side note, the XT60 connector on the V is not a standard one; does anybody know the name for this type or a supplier (see photos)

    Click image for larger version. 

Name:	IMG_3016.jpg 
Views:	195 
Size:	215.6 KB 
ID:	72868 Click image for larger version. 

Name:	IMG_3017.jpg 
Views:	149 
Size:	193.9 KB 
ID:	72869 Click image for larger version. 

Name:	IMG_3018.jpg 
Views:	241 
Size:	205.7 KB 
ID:	72870

    Thanks in advance

  3. #3

  4. #4
    Quote Originally Posted by Geodesix View Post
    Excellent, thank you

  5. #5
    Quote Originally Posted by MadmanK View Post
    As a side note, the XT60 connector on the V is not a standard one; does anybody know the name for this type or a supplier (see photos)

    Click image for larger version. 

Name:	IMG_3016.jpg 
Views:	195 
Size:	215.6 KB 
ID:	72868 Click image for larger version. 

Name:	IMG_3017.jpg 
Views:	149 
Size:	193.9 KB 
ID:	72869 Click image for larger version. 

Name:	IMG_3018.jpg 
Views:	241 
Size:	205.7 KB 
ID:	72870

    Thanks in advance
    This connector works but it will take some massaging to get it there. Here are pics of mine I just modified tonight. Its not a lot of work but I wish I knew where to get the exact match. I could not find it anywhe


    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0221.JPG 
Views:	161 
Size:	40.5 KB 
ID:	72910   Click image for larger version. 

Name:	IMG_0223.JPG 
Views:	156 
Size:	49.1 KB 
ID:	72911  
    Last edited by Lawrenmd; 1st June 2016 at 09:40 PM.

  6. #6
    Thanks for the photo's.

    I see that the MT30 connectors are on the TBS website; maybe they'll add the XT60's to the "Spares" list as well; here's hoping as that's two of us that needed some :-)

  7. #7
    Hello,
    I have found this thread. My XT60-connector is broken too. But I do not manage to loosen it. I have removed the screew between the antenna-holders and I have loosen the cube too. But I do not manage to oben the lock. Do I understand it right that the black plastic-plate with the two antenna holders and the XT-60-connector has to be removed upwards from the chassis? I can't loosen it.
    Thanks for any hints or tutorials
    Guido
    Germany

  8. #8
    Navigator
    Join Date
    Jan 2016
    Posts
    25
    Wombat; there are two tabs on the plastic piece that holds the antennas. These two tabs lock the whole piece into the larger plastic sled. You can visualize these two tabs in the upside-down picture below from my 3D printing archives. I use a flat head to push on the plastic below those tabs which helps ease them out of the locking position enough to let the piece move up and out.

    Click image for larger version. 

Name:	xt60-ant-clips.jpg 
Views:	36 
Size:	46.9 KB 
ID:	76480

  9. #9
    Navigator
    Join Date
    Jan 2016
    Posts
    25
    Quote Originally Posted by Geodesix View Post
    This does not work anymore. Anyone know where to get these XT60 with tabs?

  10. #10
    Navigator
    Join Date
    Jan 2016
    Posts
    25
    okay. I am just going to buy them from TBS then

Similar Threads

  1. Broken VTx SMA Connector
    By raumagent in forum ImmersionRC
    Replies: 17
    Last Post: 5th June 2015, 04:15 PM
  2. Antenna Connector Broken on TX
    By Slinkywinky in forum ImmersionRC
    Replies: 4
    Last Post: 20th February 2014, 11:07 PM
  3. Replies: 11
    Last Post: 10th October 2013, 06:56 PM
  4. Replies: 19
    Last Post: 24th September 2013, 11:31 AM
  5. XT60 T-Connector or parallel
    By Scotttu in forum RC TECH
    Replies: 1
    Last Post: 19th April 2012, 03:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •