Page 169 of 169 FirstFirst ... 69119159167168169
Results 1,681 to 1,682 of 1682

Thread: TBS POWERCUBE

  1. #1681
    Navigator
    Join Date
    Aug 2014
    Posts
    303
    Quote Originally Posted by noir522 View Post
    I understand you, but before I can control the servo plugged into the servo port I have to tell betaflight where the port is (the pins address ).

    I can teach you how to drive a car, but if I cant tell you what street the car is parked on then the ability to drive it is negligible.
    I believe it is UART 2. I'm reticent to pull open my copter with the powercube in it, but apparently it's written in small font on the board its self.

  2. #1682
    Click image for larger version. 

Name:	_tbs-powercube-colibri-v2-big.jpg 
Views:	8 
Size:	238.7 KB 
ID:	77221
    Ok this is where im at. I have my servo pplugged into the port labeled "servo". I read on Betaflight wiki page that servo is assigned to pb15 (B15). So in the cli tab I assigned "resource servo 1 B15". But still no control of the actual servo.
    Also I have servo tilt and forward controll active.

    How would you assign a servo to a uart port?
    1) where would you physically plug it in (requires 5v)
    2) how would you assign it in the ports tab?
    My current ports tab has :

    USB VCP . . . MSP
    UART1 . . . . . .smart port
    UART2 . . . . . . Serial rx
    UART3 . . . . . THIS IS UN ASSIGNED BUT NONE OF THE DROP DOWN MENUS SAY ANYTHING ABOUT SERVOS (OPTIONS FOR GPS, ESC AND TELEMEtry, blackbox, tbs audio, irc tramp only)
    Last edited by noir522; 26th July 2017 at 08:41 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •