image
Page 358 of 373 FirstFirst ... 258308348356357358359360368 ... LastLast
Results 3,571 to 3,580 of 3726

Thread: MWOSD - for BETAFLIGHT CLEANFLIGHT RACEFLIGHT PIXHAWK KISS DRONIN INAV and others

  1. #3571
    I don't know that hardware - but sounds like need to configure within clean flight. Then on OSD have to enable "use fc" for voltage and current tabs. This means it displays whatever the FC send its.


    Quote Originally Posted by ShortnStubby View Post
    so you got amps working without having to select use osd inside of cleanflight?

  2. #3572
    Am afraid for the moment this is the only way to configure those. Mor ein time will migrate to GUI, but it is quite a challenge due to memory available....

    Quote Originally Posted by Rogero View Post
    Hi, I was wondering about using the new GUI and Hex firmware files to update the Micro-MinimOSD to be used with Betaflight 3.1.7, what about the config.h file !
    i usually set CALLSIGNALWAYS, CANVAS_SUPPORT, ALT_CENTER, FORCECROSSHAIR, AIRMODE 30 (which was not showing onscreen with latest build even if enabled, i will test with build 1.7.1.1 tonight)

    I guess i should still use the Arduino upload method in my case, or is there a way to set the config.h parameters with the Hex files flashing method which i may have missed ?
    Thanks in advance.

  3. #3573
    Its on the todo list... not sure when it will be implemented though as quiet a few request in there.

    Quote Originally Posted by Rogero View Post
    I was trying to figure out if MWOSD is able to show the PID-values while flying like the betaflight osd does
    I can't see any reason why it shouldn't be possible to show the PIDs on the screen while flying. this would be very handy when tuning with the aux channels, makes tuning much easier and faster.
    if it's not already supported, is there any plans to implement it in future versions ?
    Thanks @Shikra for all the time and efforts you put into MWOSD.

  4. #3574
    Navigator Diverwa's Avatar
    Join Date
    Mar 2015
    Location
    Oak Harbor, Whidbey, Wa
    Posts
    110
    Quote Originally Posted by ShortnStubby View Post
    so you got amps working without having to select use osd inside of cleanflight?
    No I did use the flight controller to pass voltage and amps. Originally I assumed the holybro would manage the volts and amps being its a pdb and osd, but no still had to wire up the landings from the pdb to the flight controller.

  5. #3575
    Navigator
    Join Date
    Feb 2012
    Location
    Milton Keynes, UK
    Posts
    97
    Quote Originally Posted by shikra View Post
    @Wayno
    @CW4R

    For APM/PIXHAWK home altitude setting...

    Can one of you try new hex (Listed under TEST section in chrome GUI) or code direct from repository.

    Currently resets altitude and home first time it is armed with enough sats.
    Nice 1, will try it out and report back.

  6. #3576
    Navigator
    Join Date
    Feb 2015
    Posts
    8
    Quote Originally Posted by shikra View Post
    Is teh voltage / current sensor connected directly to the APM - or OSD. If it is APM must enable "use FC" in both "Main voltage" and "Amperage" tabs in GUI
    Correct! I did that. It's all connected within the Pixhawk and not the OSD. Is the incorrect Altitude fixed now and where can I get the link to download it?

    Ben

  7. #3577
    For volts, have you set up PIXHWAK like : http://ardupilot.org/copter/docs/com...d-pixhawk.html

    For Latest test release which includes altitude, can download hex file from here and use GUI flash from disk. minim.mavlink.hex or minim.mavlink.aero.hex

    Quote Originally Posted by CW4R View Post
    Correct! I did that. It's all connected within the Pixhawk and not the OSD. Is the incorrect Altitude fixed now and where can I get the link to download it?

    Ben

  8. #3578
    Navigator
    Join Date
    Jan 2016
    Location
    Germany
    Posts
    11
    I have a general question regarding GPS time display and it's accuracy.
    I'm using MultiWii 2.4 with activated GPS time display coded.
    Since I'm using MWOSD R1.6.8.0 I thought it would be best to post here.
    The problem I'm having is that the GPS time being displayed is highly unreliable.
    Having 8-10 satellites I can't get minute accuracy let alone hours at times.
    I live in central Europe. I have "Time Zone" = OFF. Today I had to set the Offset to 11 for the correct time to be displayed. Yesterday it was a different value.
    Does anyone have experience with the setup?

    Thanks.

    Leo

  9. #3579
    Jeez - didn't know anyone was still using that!!

    Not sure I can help much - the code hasn't changed in years! I am looking to implement GPS time support for ublox standalone operation in a while which may help test OSD code.

    Just to confirm - this requires special patched version of MultiWii 2.4 - its not in standard code. It sound like you have that already. I think without you will get varying false time







    Quote Originally Posted by ///Leo View Post
    I have a general question regarding GPS time display and it's accuracy.
    I'm using MultiWii 2.4 with activated GPS time display coded.
    Since I'm using MWOSD R1.6.8.0 I thought it would be best to post here.
    The problem I'm having is that the GPS time being displayed is highly unreliable.
    Having 8-10 satellites I can't get minute accuracy let alone hours at times.
    I live in central Europe. I have "Time Zone" = OFF. Today I had to set the Offset to 11 for the correct time to be displayed. Yesterday it was a different value.
    Does anyone have experience with the setup?

    Thanks.

    Leo

  10. #3580
    Navigator
    Join Date
    Jan 2016
    Location
    Germany
    Posts
    11
    I haven't used the OSD in nearly 1 1/2 years. Had almost forgotten on how to use it :-)

    Well well.... I guess I don't have everything setup correctly after all because I'm using the standard MW 2.4 code.
    Where can I find the "patched" version?
    Last edited by ///Leo; 15th June 2017 at 12:29 PM.

Page 358 of 373 FirstFirst ... 258308348356357358359360368 ... LastLast

Similar Threads

  1. Why won't baseflight connect on my Mac ?
    By Sortie72 in forum OSDs & Flight Controllers
    Replies: 45
    Last Post: 24th November 2015, 01:14 AM
  2. TBS DiscoPro + MultiWii (Baseflight on Naze32) PID regulation
    By Asurendra in forum OSDs & Flight Controllers
    Replies: 10
    Last Post: 7th January 2015, 01:41 PM
  3. 400Q Specific Baseflight firmware for Naze32
    By chatch in forum REALFPV.COM
    Replies: 72
    Last Post: 29th April 2014, 08:41 AM
  4. HELP GUYS LIKE ME THAT REALLY WANT TO CROSS OVER TO NAZE32/MULTIWII
    By Bigjack in forum OSDs & Flight Controllers
    Replies: 28
    Last Post: 28th February 2014, 01:22 AM
  5. need help multiwii pro
    By florinb31 in forum OSDs & Flight Controllers
    Replies: 2
    Last Post: 23rd May 2013, 12:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •